开始

好易软件工作室

温州市民航路文景花苑2#1007

电话: 0577-88330371

Email:163_zhp@163.com


关于好易餐饮管理系统

欢迎使用好易餐饮管理系统,好易软件工作室于2003年5月份推出的酒店管理系统是一套全面的酒店餐饮行业管理系统,适合于中餐厅、西餐厅、宾馆、洗脚城、康乐中心、健身房、美容店等等餐饮娱乐行业企业使用。

好易软件工作流程图:

本餐饮管理系统软件具有如下一些优点:

1.界面新颖,布局合理,操作方便,稳定可靠,性能优秀.本软件所有的操作都可以通过键盘完成,全程的快捷键可以让收银员以非常快的速度完成点菜单的录入,买单,打单以及改单.

2.可视化的收银账单格式设置可以准确的调节结账单打印样式.

3.完善的权限设计方案,可以有效的防止收银员随意的操作单据.

4.优秀的网络联机性能，可以支持多达16台计算机同时协同工作

5.完善的数据库备份恢复功能，确保您数据安全无忧

6.可视化的报表设计器，让您轻松打印想要的报表

好易餐饮管理系统采用Visual C++6.0 + Visual Basic 6.0 + Windows2000平台开发，为了正确运行本软件，您的计算机硬件系统需要达到如下标准：

奔腾200MHZ以上CPU

64MB以上内存空间

600MB以上硬盘空间

软件系统需求：

Microsoft Windows9X/Windows2000/WindowsXP/Windows Server2003等等操作系统


中餐

部分典型客户名单
温州五马美食林鸿华大酒店 | 温州五马美食林名豪大酒店 | 温州五马美食林大自然会所 | 温州观松楼吴桥大酒店
温州观松楼解北大酒店 | 温州溢香厅大酒店 | 温州新溢香厅大酒店 | 温州露天食街
温州市巴乡小镇上陡门店 | 温州市巴乡小镇马鞍池店 | 温州市永强镇张记燕鲍翅馆 | 温州市妙鲜阁大酒店
温州市妙鲜阁食街 | 温州市桃源山庄大酒店 | 温州市鑫顺调料批发有限公司 | 温州市口福快餐丽水加盟店
温州市康园大酒店 | 温州市下吕浦锦园鱼味馆 | 温州市湘菜鱼头王大酒店 | 温州市江滨路1号美食坊
温州市楠溪第一楼_胜利路店 | 温州市楠溪第一楼_公园路店 | 温州市楠溪第一楼_瓯北店 | 温州市楠溪第一楼_瑞安店
温州市渔寮海鲜楼 | 温州市精伍鸭头_环球总店 | 温州市精伍鸭头_下吕浦店 | 温州市精伍鸭头_飞霞南路店
温州市好人家海鲜食街 | 永嘉县瓯北镇王府大酒店 | 永嘉县瓯北镇楠溪江大酒店 | 永嘉县瓯北镇美瓯食街
永嘉县上塘镇阿正酒店 | 永嘉县上塘镇金潮大酒店 | 瑞安塘下镇景阳大酒店 | 瑞安塘下镇珍味楼大酒店
瑞安市梅头镇新街口餐饮有限公司 | 瑞安市汀田冷双大酒店 | 瑞安市东园美食街 | 瑞安市洞庭乡土菜馆
瑞安市钟锦记沸腾火锅店 | 乐清市白象镇正兴大酒店 | 乐清市虹桥镇虹丰大酒店 | 平阳溢金香大酒店
平阳天龙大酒店 | 玉环县海上花园大酒店 | 温岭市京宫大酒店 | 南昌市天龙大酒店
温州市舍得坊休闲餐饮 | 温州市莱克利迅自助餐厅 | 温州爵士岛咖啡美食 | 名典咖啡语茶乐清店
名典咖啡语茶温州店 | 名典咖啡语茶_欧北店 | 名典咖啡语茶_玉环店 | 名欧咖啡_温州店
名欧咖啡_永强店 | 吉祥阁咖啡美食 | 瓯北罗森堡咖啡美食 | 乐清市柳市镇风雅咖啡厅
乐清市蓝山咖啡 | 星期八酒吧_乐清店 | 星期八酒吧_虹桥店 | 星期八酒吧_柳市店
青田县青溪镇米兰酒吧> | 台州F1慢摇吧 | 温州市三球健身俱乐部乐部 | 温州市飞速健身俱
温州市健之美健身俱乐部 | 温州市壹周健身俱乐部 | 温州市瑜汇珈园 | .......


无标题文档

=================================================
=好易餐饮管理系统更新记录
=EMailTo:4108173@qq.com
=================================================
2012.04.26
1.更新:服务器增加了动态发送数据库配置信息的功能(以前有提供过此功能,后被取消).

2012.04.25
1.更新:菜品出品时间报表增加了按照制作总时长排序的功能

2012.04.20
1.更新:营销管理系统增加了到点向老板手机发送营业数据报告的功能

2012.04.12
1.更新:账单打印增加了打印服务员名字的功能

2012.04.01
1.更新：出品小票上面的下单时间改为提交时间

2012.03.27
1.更新:小票打印模板调整了打印效果,增加了分隔线以及小计字体控制(实收金额)
2.更新:数据中心初始化数据库添加了项目删除所有客户资料(慎用)

2012.03.26
1.更新：前台收银增加了权限允许占用的权限

2012.02.24
1.更新:转移某个菜品时自动打印该菜品转台通知(目前会打印在该档口所有的打印机上)FOR金华兰溪伯爵咖啡
2.更新:出品台划菜窗口上显示菜品的排序顺序可以选择先后顺序排序规则.For金华兰溪伯爵咖啡改进

2012.01.17
1.更新:报表模块增加了菜品制作时间报表
2.修正:上个版本修改的授权错误问题

2012.01.10
1.更新:会员种类添加了新的属性:禁止充值,用于解决折扣卡和充值卡严格区分的场合
2.更新:局部变更了试用版授权模式

2011.11.12
1.更新：客户过滤可按工作单位名

2011.11.08
1.更新：新的更新机制各个模块可以自行更新自己所需文件，而无需经过先前的人工设置更新模板

2011.09.10
1.修正：前段时间版本修改导致的帐单上实收金额与数据中心中设置不匹配的BUG
2.更新：提供了基础版的成本核算架构。
3.重大更新：提供了数据库版本的自动版本更新检查机制，可以无需人工操作自动更新本地营业和远程VIP数据库版本。

2011.09.08
1.更新：营销管理模块的菜品管理页面增加了组合框选择类别
2.重大更新：取消了StormLib.dll的模块，库存管理准备采用日结方式执行

2011.08.31
1.更新:出品模块里面按下小键盘的+弹出选择在用餐桌的列表,便于查询餐桌菜品
2.更新:前台收银输单模块的指定菜品状态的框根据权限被禁用

2011.06.27
1.更新:前台收银的结帐窗口字体放大,面积放大
2.更新:前台收银的餐桌菜品显示增加了图标,重新设置了列顺序
3.更新:修改账单界面的历史账单的菜品允许免费.

2011.06.17
1.更新:挂账客户添加了是否允许挂账的属性,结帐界面的选择挂账客户时可以按照该属性过滤,缩短从远程服务器访问客户资料的等待时间.

2011.06.14
1.更新:账单的挂账客户和刷会员卡客户分开保存
2.更新:预订登记界面,增加了保存时发送短信提醒,来电号码加大显示
3.更新:客户资料编辑保存时增加了手机号重复判断

2011.06.01
1.重大更新:前台模块取消了VB的FlexGrid控件的调用.

2011.05.19
1.重大更新：正式支持连锁店模式，功能包括基础数据的下载，营业数据的上传，和总店的报表查询

2011.05.15
1.修正:前台收银执行换台时如果指定的源餐桌和目的餐桌相同会导致死循环的BUG

2011.05.13
1.更新：启用了新架构LibCanYin.dll

2011.05.12
1.更新:预订登记界面取消了,客人口味等项目,增加了消费次数,平均消费和预订次数信息
2.更新:客户资料编辑界面增加了客户备注页面,但是限制字符长度为200字符.
3.更新:营销管理系统增加了设置系统选项功能.

2011.05.09
1.更新：会员积分扣除
2.修正：删除某条会员消费记录会删除该会员所有消费记录的bug

2011.05.07
1.更新：库存模块修正了一些错误
2.更新：报表模块在打开备份数据库的时候，忽略F_TableCount字段

2011.04.13
1.更新:营销管理模块添加了营业数据过滤导出到XML文件的功能

2011.04.08
1.更新:结帐界面能读取临时账单的折扣信息等.
2.更新:关台后菜品立即消失.

2011.03.26
1.更新：完成了服务器自动备份数据库的插件

2011.02.15
1.修正:已免费菜品无法再修改数量的BUG

2011.01.17
1.更新:会员管理里面,指定关键字查询时也在总界面上刷新积分记录
2.更新:前台收银修改密码那里修改成功后给个提示.

2011.01.04
1.更新:会员管理删除会员的消费记录时,如果是在调试模式下则可以彻底删除记录,非调试模式则只是红字处理
2.更新:数据库更新工具增加了更新项目失败即终止的功能
3.更新:库存模块修正了在入库单据操作时散装单位和包装单位的价格换算关系
4.修正:库存模块修正了期末转结时的实时错误问题.

2010.12.30
1.修正：会员管理在营销中心可以维护远程vip库的会员种类资料了
2.修正：前台收银可以正确的处理远程会员库的折扣方式了。

2010.12.27
1.修正:前段时间修改导致的不能启用远程VIP库的BUG

2010.12.10
1.PDA打开主页:楼层无分类[此问题待厂商解决]
2.点热菜与冷盘的桌数不同的,不能点
OK 解决办法:如果遇到这种情况,请点菜员在冷盘点好后发送之前附加点一个[冷盘加一桌],再发送
3.手工点菜用PDA加菜,所有菜单重出一遍,导致重复
OK 此问题已经解决,手工输入的菜品不再出现在值台单上,[以后也渐渐会没有手工单]
4.简拼都是共享,没有分类(冷盘\粤菜\瓯菜\酒水等)
此问题需要等厂家答复,在修改中,此举为提高操作效率
5.点菜单上同时出现叫起上菜,导致重复,自相矛盾.
OK 已解决:思路是该餐桌打印值台单的命令发出后,即清空台面备注如叫起等(但是桌数不变,加菜时不会按照桌数翻倍数量,而且小票上,厨师只管按照实际数量出品即可,基本无需考虑桌数,海鲜除外,海鲜需要用附加备注解决,多沟通)
6.跨楼层的点菜单只出一张[实际是指值台单]
OK 已解决:批量开台的效果做到了主从餐桌的概念,当主餐桌被指挥打印值台单后,程序会自动把所有从桌的值台单也分别打印一遍到各个楼层的打印机,并在抬头上面以 从桌[贵01]的形式标出[注意:如果客户觉得单子太多,如几个桌子都在同一个楼层,我们还可以改为一个楼层只打一张,这个问题看实际效果决定,反正很好解决]
7.PDA屏幕破裂
OK 已解决:我公司已花费400元进行修复,希望对方要管理好设备,而不是说未交接就由我方负责,这是不讲道理的[周总原意如此:我方负责].
8.PDA网络覆盖区域信号不好,导致PDA死机
分析:机器个别出现死机,网络不通,是无法避免的,正茂也肯定有此情况.
9.PDA不小心多开一桌台,必须到收银台取消
OK 解决办法:pda上可以直接关台(前提是关的那个餐桌里面没有菜品)
10.PDA不能直接转台(吧台转台后,每楼层都出转台单)
此问题不重要,暂没改,浪费不了多少纸
11.划菜口出单,出两份(红色纸张无需出)
建议客户更换纸张类型,购买单层的卷筒打印纸
我方内部主动修改内容:
1.收银台打印值台单时会确认是否打印全部的菜品,或者打印增加的菜品,或者取消,防止补打值台单时一下子把全部菜品打印出来
2.通过修改上述打印值台单的功能的过程发现了潜在的不打印值台单的故障原因,现在代码已经调整过来,已经解决,基本不会再出现三楼值台单不打印的BUG

2010.12.08
1.重大修正:彻底解决了零头舍入选项的潜在逻辑错误
2.修正:数据中心无法修改班次时间
3.修正:营销模块添加客户资料,空界面按回车会出错

2010.12.03
1.更新:账单格式设计器添加了两个选项:预接账单标志[账单标志]如果该项目的是否打印设置为是,而且指定了打印位置,则在F9和F8打印时打印不同的标志[预结单][结账单],但是修改账单里面统一会打[结帐单]
2.更新:添加了[打印菜品备注]项目,当该项目设置为是打印和坐标不为0后,如果菜品附带了做法资料,则会在账单上附带打一行做法行.

2010.12.01
1.更新:收银和下单模块显示餐桌已点菜品的界面上增加了单位列(以及是否显示单位列的选项)
2.更新:服务器自动备份数据库的计划任务功能即将完成(目前打算采用插件形式).

2010.11.24
1.更新:包房点单系统增加了单图选菜功能

2010.11.21
1.更新:数据中心模块查看选项添加了指定点菜图片路径 可以将菜品图片按照新格式指定到任意网路共享地址
2.更新:包厢点菜系统中的菜品图片保存路径为 \\服务器\图片\类别名\菜品名_s.jpg
3.更新:菜品增加了图片属性,默认与名称相同,但不能包含特俗字符

2010.11.19
1.更新:手工输入的单子默认为已经打印过值台单

2010.11.17
1.更新:完成了万谷科技WG606MF-SU型读卡器接口程序,可以应用于瑞安唐朝投资会所
2.更新:正式开始支持非接触式IC卡(射频卡)类型的会员卡了.

2010.11.16
1.更新:营销管理里面的预定记录界面上添加了按钮[生成短信],可以根据输入的预定记录自动重新生成短信文本,方便用户操作
2.更新:收银模块中查看选项里面管理IC卡插件窗口的界面上对插件DLL文件名做了排序处理,便于查找

2010.11.13
1.更新:PDA版点菜器增加了口味加价的功能

2010.11.11
1.更新:增强了日志系统的文件操作功能,防止频繁写文件造成错误.
2.更新:修正了库存模块的用户权限不同步的BUG
3.更新:部分规范了日志系统的格式
4.更新:数据中心菜品管理增加了批量设置菜品的沽清/取消功能
5.修正:数据中心中菜品分类项目的自动重设编号设置为根据选项里面设置的代码长度中的类别编号长度自动设置
6.更新:数据中心模块中菜品分类项目的显示格式(列宽度和新属性)
7.更新:库存模块初步支持二级商品分类

2010.10.29
1.更新：制单程序添加了打印总单副本到多个打印机的功能（虚拟出品部门）
2.修正:前台收银模块,在设置了连接VPN远程VIP库后,由于VPN不通,结帐和刷会员卡时会导致程序崩溃的bug,改为忽略无法连通的方式,但是会超时比较长的时间.

2010.10.28
1.更新:数据中心里面自动重设菜品编号可以选择分类重置而不必重置所有编号
2.更新:数据中心里面基本项目的重置编号按钮只在调试模式才显示出来
3.更新:国宇版基站程序中的附加项目"打印值台单"处理流程做了优化,最大可能简化操作.

2010.10.22
1.更新：增加了台面备注功能适应国宇PDA功能以及跟PALM版统一

2010.10.13
1.更新：报表查询增加了查询远程VIP数据库数据的功能

2010.10.12
1.更新：客户管理添加了重置所有编号的功能

2010.10.11
1.更新:增加了会员资料的导入导出功能.

2010.10.08
1.更新:菜品类别增加了属性 不上PDA 代表包房点菜模式下 这个类别的菜品是否显示在屏幕上

2010.10.04
1.更新：增加了会员资料的上传功能，扩展支持多分店系统
2.更新:数据中心餐桌项目增加了导入和导出数据功能
3.更新:库存模块修正了若干集成错误.
4.更新:库存模块增加了单据打印选择模板的功能

2010.10.03
1.更新：预订登记修改了界面，扩大窗口，增加了排菜等功能
2.更新：数据中心增加了基本元素以及菜品资料的导出导入功能

2010.09.24
1.更新:会员管理的若干查询页面都添加了按照卡种过滤的功能

2010.09.12
1.更新：报表模块的会员消费汇总报表里面添加了指定会员种类的功能

2010.09.10
1.修正:会员报表里面一个充值记录同步删除查询的BUG

2010.09.03
1.更新：账单上打印VIP制卡店、VIP卡种，用于多分店IC卡共享客户资源
2.修正：会员模块非系统管理员不能修改选项。等

2010.09.02
1.更新：完善了客服版本控制，以及因特网版本控制，比较容易自动升级。

2010.08.28
1.更新：IC卡读取界面添加了直接显示折扣状态等字段的元素

2010.08.27
1.修正：刷IC卡，选项“只扣款不打折”无效的BUG
2.修正：会员管理页面上，右键选择修改删除会员会提示找不到会员的BUG（会员ID逐渐增大，超过了旧版本处理数字范围，同步造成）。

2010.08.23
1.修正：服务器和配置工具的自启动判断方法，另外发现新版360卫士对自启动项目屏蔽比较大
2.更新：会员管理增加新权限“允许修改会员折扣方式”

2010.08.21
1.修正：服务器和配置工具设置自动启动的一个判断BUG
2.更新：会员IC卡共享会员的折扣方式和折扣率属性，写入IC卡。
3.更新：会员IC卡中保存附加的折扣率和打折方式，以及修正了老版本会员价属性.

2010.08.15
1.更新:推出全新版的客户端自动配置更新工具和服务器
2.修正:包房点菜系统,分类选择菜品,选中点菜后不能正确更新已点状态(绿色标记)的bug
3.修正:前台收银模块中,结帐界面上,没有将IC卡扣款过程纳入数据库事务处理的bug(有可能导致IC卡余额与数据库不符)
4.更新:注册模块中如果读取硬盘编号失败,那就读取首个网卡编号.

2010.08.06
1.更新：IC卡付款方式的余额打印功能
2.更新：报表模块的菜品销售汇总报表添加了按照接账单所属服务员编号过滤的功能
3.更新：触摸屏点菜系统的分类点菜确认后返回上一界面，所点菜品以绿色标题表示，菜品缩略图下面显示标题，颜色代表是否已点。

2010.08.02
1.更新：前台收银添加了删除指定日期范围的账单数据的功能

2010.07.21
1.更新:前台收银模块在进入结帐前刷新一下当前餐桌的信息,防止不同步
2.更新:报表模块支持新版日志系统
3.更新:报表模块查询客户挂账报表可以只输入名字中的一个字即可模糊查询.

2010.07.19
1.更新:针对舟山外滩风情咖啡的情况增加了前台收银的餐桌状态同步功能[有选项开启和关闭].

2010.07.18
1.更新:针对舟山对出品程序的餐桌菜品刷新过程做了修改,不限制餐桌状态
2.更新:临时将账单打印的客户会员卡余额在打印时刷新一次(暂不考虑分店联网和IC卡模式)

2010.07.12
1.更新:收银前台的刷卡模式做了重大修改,一次只有当前窗口可以接受刷卡信息
2.更新:前面修改导致的单机版不能正确启动服务器的BUG
3.更新:前台收银界面上刷会员卡显示余额的临时解决办法.
4.更新:工作站和服务器增加了客户端版本号对比机制,确保工作站可以自动升级.
5.更新:DBUpdate创建数据库成功后，把最终的数据库文件路径信息保存下来.

2010.07.09
1.更新:账单设计器的默认路径
2.更新:前台收银结帐时处理包厢费和最低消费关系
3.更新:POS下单系统中操作员快速重复登录默认保持到上次操作的餐桌的功能.

2010.07.05
1.更新：新菜品消息处理过程中自动更新餐桌使用状态的功能
2.更新：添加非消息模式参数，解决在同一机器上运行多套系统的缓冲办法。

2010.07.02
1.修正:最近优化修改导致的基站程序不能正确排序菜品的BUG
2.更新:修复了新版用户管理自动添加默认用户的功能
3.修正:修复了服务器非法使用指针发生意外退出的BUG
4.重大更新:启用了新版日志传输系统,可以保存更详细更长的日志信息.

2010.07.01
1.修正:最低消费模式启动的情况下,打折无效的ＢＵＧ

2010.06.29
1.修正:前面优化结构导致的收银模块没读取最低消费额的BUG
2.更新:前台模块可以动态指定服务器IP,增加用户友好度

2010.06.28
1.更新:前台收银修改了一个防丢流水号的功能
2.更新:服务器增加了动态图标.

2010.06.27
1.修正:最近修改导致的Config.exe不能自动开机更新程序的BUG
2.修正:报表查询系统里面的营业汇总报表的合计数字错误的BUG
3.更新:服务器的注册机制,避免工作站出现未注册提示,增强注册稳定性

2010.05.31
1.修正:IC卡刷卡余额打印以及客户充值付款记录的保存处理方面一些小BUG
2.更新:会员管理之客户充值付款记录列表里面增加了事后余额列.
3.更新:服务器加了加密调试项目,便于诊断注册授权失败的日志.

2010.05.24
1.更新:前台收银中未买单统计功能转移到F7前台收银交班窗口,可以复选包含未买单统计数据
2.更新:用户权限检查无权限时提示该权限的名称
3.更新:去除了结帐时的包厢费项目,厘清了最低消费跟包厢费之间的逻辑关系
4.更新:重新调整了数据中心里面的选项页面,去掉了刷卡器页面

2010.05.23
1.更新:会员卡充值添加了付款方式字段
2.更新:报表查询添加了会员充值报表和会员消费报表两个报表

2010.05.21
1.重大修正:排除了所有模块中都可以输入价格为负数的菜品的BUG
2.更新:PALM基站程序添加了在调试模式下每点一个菜品发送一次日志的功能

2010.05.20
1.更新:厨房出品小票的餐桌编号前面可以自定义标题了
2.更新:厨房出品小票里面添加了餐区项目
3.更新:前台模块开放了选项,显示餐桌之间的间距
4.重大更新:餐饮前台模块增加了餐桌图片风格自定义功能
5.更新:出品小票中,连桌打印时,数量\单位\价格打印在第二行,防止菜品名称过长导致价格打印不出来

2010.05.16
1.更新:添加了系统选项:是否允许有菜品数量为0的餐桌进入买单结帐界面
2.修正:在F7禁止显示已经被覆盖的账单数据,跟报表保持一致.

2010.05.06
1.修正:前段时间修改导致的在数据中心中打开了新版的用户权限管理页面后,退出时整个数据中心模块会退出的BUG

2010.05.05
1.修正:前台收银模块在使用会员卡充值消费时,一张账单刷几张会员卡扣款处理出错的BUG

2010.04.30
1.修正:会员卡扣款时一个打印余额不正确的问题（时效问题）

2010.04.27
1.修正:最近修改导致的VIPMIS里面修改会员密码窗口弹出错误

2010.04.14
1.更新：前台收银结帐时允许部分签单了

2010.04.12
1.修正：前面修改导致的选项冲突

2010.04.03
1.更新:数据中心和报表模块增加了菜品核算类别"不计算入营业收入总额"属性[应私享国菜要求]
2010.03.27
1.修正：使用IC充值卡时会自动覆盖客户信息，丢失客户联系电话等信息的BUG
2.更新：短信管理支持浙江联通短信接口。
3.更新：出品程序取消了重复提示划菜口打印机

2010.03.20
1.修正：修复潜在的重复ID的BUG

2010.03.17
1.修正：收银系统中结帐时不能正确打印IC卡当前余额的BUG

2010.03.01
1.更新：酒店营销管理程序支持4路录音盒了
2.更新：酒店营销管理程序的来电弹出窗口，在主程序窗口最小化时不会最小化

2010.02.28
1.修正：最近修改导致的出品模块不能成功清空历史出品记录的BUG[路径不一致，现在已经转向到LOG目录]

2010.02.25
1.修正：会员管理模块不能正确在列表中显示会员分类的BUG

2010.02.06
1.更新：调整了小票打印机模式下账单上打印会员充值卡余额的格式（也可以紧跟菜品打印费用了）
2.更新：收银模块增加了收款小数点不舍也不入的功能
3.修正：账单打印模块中不能正确控制数量列的字体大小的bug
4.修正：账单设计器中冗余显示酒店名称地址和电话的失误（不再显示数据中心设置的内容，以填写的内容为准）

2010.01.31
1.更新：为金汇大酒店在出品程序的出品部门选项里面添加了打印整单副本到划菜口打印机的功能
2.修正：新版用户权限管理中的操作员最低折扣率没有取组别折扣率的BUG

2010.01.20
1.更新：异店刷IC卡，可以同步使用会员价功能

2010.01.14
1.更新：增加了静默模式选项，某些模块（无线基站）在数据库连接失败时不再弹出错误提示，保持程序无需人工干预。

2010.01.13
1.更新：收银模块添加了一个常规选项，在空闲的餐桌上显示座位数。
2.修正：数据中心新版用户权限管理中用户组管理的一个bug(无法修改组名称)

2010.01.11
1.更新:管理员密码规则做了调整。
2.修正：添加新菜品界面上的部门字段标题修改为“出品部门:”

2010.01.10
1.修正：基站程序自动更新数据时可能不正确更新菜品口味数据的BUG，该BUG导致点菜器无法正常的输入菜品的口味。
2.更新：出品划菜程序的锁定工作站桌面选项可以在服务器端选项里面设置。

2010.01.07
1.更新：增加了在收银选择出品部门打印该部门出品汇总报表的功能。
2.修正：前面修改导致的重新点击登录窗口时无法正确自动选择班次的BUG。
3.修正：会员管理模块中在收银结帐时如果刷的是新的会员卡，自动生成会员卡时，如果首选客户类型的折扣率为0，那么默认修改为100，即不允许打折。

2010.01.03
1.修正：出品模块里的祥单格式打印会重叠
2.更新：服务员的值台单上要打印上菜备菜等附加信息

2010.01.02
1.修正：餐饮账单设计器前面修改导致的不能正确读取核算类别的bug

2009.12.21
1.修正：最近修改导致的打印某桌详单时会把已经取消的菜品显示出来的BUG

2009.12.15
1.更新：出品打印模块重新恢复了一个出品部下多个打印机分餐区打小票的功能，如果不给打印机指定餐区则所有打印机都按各自要求打一次。
2.更新：报表模块的菜品销售汇总和明细报表增加了按照点菜员名字过滤的功能

2009.12.13版本:7.10.393
1.更新：报表程序支持新版的目录结构
2.更新：报表模块中的菜品销售报表添加了按照核算类别汇总和排序的功能
3.更新：HySetup.exe工具支持新版的目录结构
4.修正：新版的无线基站程序支持全动态数据更新（无需退出）

2009.12.06版本:7.10.392
1.修正：新版用户权限管理里面的删除用户组会强制删除该组所有用户的bug
2.更新：新版用户权限管理里面把用户列表放在第一个页面，适合新手操作习惯
3.更新：收银模块中打印餐桌详单增加了按照加菜的先后顺序将每次打印详单后再加的菜与原先菜品用横线分割（此功能仅影响详单打印和档口连单打印）

2009.11.26版本:7.10.391
1.更新：菜品属性里面添加了“允许PDA使用”属性，可以将酒水、附加项目之类的产品不上传到PDA
2.更新：新版程序里面添加了自动更新配置文件的批处理程序“转档.bat”

2009.11.16版本:7.9.390
1.修正：各个模块注册的BUG,服务器的注册码保存到 HH\Config\Server.ini文件
2.更新：餐饮收银模块的账单打印格式文件保存到 HH\CONFIG\账单格式.ini[账单设计器已经更新]
3.更新：所有模块支持OEM.INI定制公司信息，方便推广代理版
4.更新：出品模块增加了完善的桌面锁定模块(联机开始工作后自动锁定工作站桌面，无法执行其它任何操作)
5.更新：DBUpdate.exe程序自动更新数据库时再也不会出现“超时过期”错误了
6.更新：消息处理过程做了优化加强，吸收了优创软件的一些优点
7.更新：日志系统做了增强，提高了美观度

2009.11.14版本:7.8.389
1.更新：报表查询增加了debug启动参数，开启调试模式，另外增加了导入界账单的功能（在导入界面里面）
2.更新：报表查询的数据库导入里面，默认只导入基础资料，不导入账单，进调试模式后可以导入
3.更新：收银模块打印值台联可以在设计器里面设置是否打印合计金额了，格式文件也做了变化，需要用新版格式文件覆盖
4.更新：收银模块打印值台单时会在小票上页头打印“值台单”字样
5.修正：统一了出品模块的出品日志文件所在位置："\Log\出品记录.txt"

2009.10.25版本:7.8.388
1.更新：会员管理模块的会员资料读取做了大的修改，一般情况下不读取所有客户资料，需要用户输入关键字后查询（应对大数据量的情况），收银模块中挂账时也是如此

2009.10.23版本:7.8.387
1.更新：收银模块结帐界面上增加了消除客户资料按钮（对于已经保存过有会员卡的账单）

2009.10.14版本:7.8.386
1.更新：收银模块中增加了直接修改已点菜品的口味做法数量单价状态等信息（用权限控制）
2.更新：出品程序中打印餐桌详单，直接选择打印机名称
3.更新：palm基站程序中增加了修改台头信息、换台等功能
4.更新：微调了出品程序和收银模块中打印连单详单的格式(缩小了间距)
5.更新：收银模块中提交菜品时可以选择提交模式：即上 备菜 或者自己输入
6.更新：基站程序中增加了上冷盘 上主菜通知功能
7.更新：出品程序中增加了上冷盘 上主菜等通知消息打印的功能
8.更新：出品程序中打印详单可以直接选中本机的打印机进行打印了（以前是选择出品部门，太复杂了）

2009.10.11版本:7.8.385
1.更新:出品模块的小票打印格式做了重大调整(价格和数量移动到名称下面一行)
2.更新:出品程序中的部门和打印机的逻辑关系做了调整，一个部门可以带多个打印机打印不同的格式（分区打印功能暂未测试)
3.更新:收银账单打印格式修正了一些错误(多重选项之间的逻辑关系)
4.更新:出品程序增加了定时刷新（防止丢单）自动抢光标（无串口条码枪的情况下）
5.更新:出品模块完成了主食通知的功能（未完全测试）
6.更新：出品模块增加了各档口打印机打印测试页的功能
7.更新：收银模块增加了数据刷新的功能（防止丢单）
8.更新：PALM基站程序增加了：用户密码修改、防止重复开台、同时开多个台、修改已点菜品口味等功能

2009.10.07版本:7.8.384
1.修正:基站和出品模块自动重新连接服务器后数据不完整的错误
2.更新:所有POS模块在接收到新菜品处理消息后对界面的同步方式，修正了潜在的不同步显示的BUG
3.更新:预留了厨房上主食后小票通知明档的接口(暂未完成)
4.更新:无线基站程序中增加了如果是非法的口味编号的话，点菜时返回错误信息给点菜员
5.更新:预留了调试餐桌字段的功能(暂未完成)

2009.10.06版本:7.8.383
1.更新:针对德胜楼做了个专用补丁（账单打印库）对其它客户无影响

2009.09.29版本:7.8.382
1.更新：账单设计器和收银账单的打印功能在使用小票打印机的时候末尾备注行的空白行数可以指定

2009.09.27版本:7.8.381
1.更新：套餐菜品增加菜品明细的选择窗口更新为快速查询样式

2009.09.17版本:7.8.380
1.更新：前台收银F7结帐报表里面修改了数据汇总样式，并且增加了按照小票打印机打印的功能
2.更新：前台收银增加了选项 打印双份的结帐单（在使用热敏打印机时）
3.更新：前台收银等模块修改了菜品过滤框的显示程序，提高了程序效率
4.更新：各个模块统一了菜品备注选择模块，加强了操作手感,修改菜品资料中的增加口味框更方便使用，可以显示已经存在的口味了

2009.09.13版本:7.8.379
1.更新：菜品增加了出品部二的功能（解决海鲜经由两个部门配合处理的过程）
2.更新：修改了菜品的口味数据的组织方式。
3.更新：出品程序增加了部门的总单打印选项。
4.更新：出品程序增加了按照菜品的出品部二的设置在两个部门打印小票的功能。

2009.09.04版本:7.8.378
1.更新：服务器添加了按照配置文件Server.ini文件中的自动启动项目启动出品程序的功能

2009.09.03版本：7.8.377
1.修正：多个分店共享IC充值卡的数据同步处理问题
2.修正：会员管理模块不能正确导出数据到EXCEL的BUG

2009.08.24版本:7.8.376
1.更新:数据中心数据导出到Excel的bug
2.更新:数据中心重置所有菜品编号的功能,增加了按照菜品名称读取记录,便于查找重复菜品

2009.08.21版本:7.8.375
1.修正:IC卡充值扣款方面一些操作方便性,以及结帐时对IC付款方式的处理错误的BUG
2.更新:会员管理模块,输入会员号码后直接按回车键可以检索会员信息

2009.08.04版本:7.8.371
1.重大更新:前台收银中账单增加了打折方式字段，其值共有三种模式 不打折 部分打折 全部打折,会员折扣率方面的潜在漏洞已经解决，以类别折扣和会员折扣取低值使用
2.更新：前台会员短信的准确发送，防止在多次打印账单时重复发送短信记录。

2009.08.01版本:7.7.370
1.更新：会员管理模块添加了短信批量发送功能，前期短信记录直接写入临时数据库，在会员管理的短信管理页面上统一延迟发送，时间间隔为1分钟,保持了程序的数据处理的高效率。

2009.07.31版本:7.7.369
1.更新:会员短信支持wavecom短信猫
2.数据中心:初始化业务数据窗口进入时自动选择默认选项（更易于使用）
3.修正:报表导出营业数据的一个潜在错误
4.更新：报表导出营业数据增加一个选项“使用临时文件”，如果不选则不产品临时文件（更安全）

2009.07.24版本:7.7.368
1.更新：前台收银刷会员充值卡结帐时弹出专用刷卡界面,可以刷卡和输入密码,以期对键盘口的刷卡器更好的支持

2009.07.23版本:7.7.367
1.更新:会员管理系统和前台收银系统增加了会员卡余额变化短信通知功能.

2009.06.28版本：7.7.364
1.更新：出品程序中的出品部门选项设置里面添加了选项"在小票上不打印价格"

2009.06.06版本:7.7.363
1.更新:加快了系统的启动速度,读取菜品表时采用了优化算法

2009.06.02版本:7.7.362
1.更新:7.7版本添加了数据库访问的Ado开关,支持用Ado 1.5访问大量数据,提高效率
2.修正:完全修正了以前名欧服务员用下单程序提交后马上取消的漏洞,以前5秒取消限制仅仅针对于刚输入的菜品,而无法防止对于提交做取消,因此无效

2009.06.01版本:7.6.361
1.更新:会员管理模块的会员读取速度做了优化[去除了重复读取数据过程]

2009.05.30版本:7.6.360
1.更新:预订管理模块增加了日志功能

2009.05.16版本:7.6.359
1.更新:会员管理添加了动态刷新会员充值余额的功能

2009.05.13版本:7.6.358
1.更新:收银程序添加了快速选择餐桌的对话框,当餐桌编号里面有汉字时也可以快速用键盘选择了

2009.04.27版本:7.6.357
1.修正:出品程序有时重复打单的BUG
2.修正:报表程序导出数据有时会提示"发生内部错误"的BUG

2009.04.24版本:7.6.356
1.更新:出品程序加入了调试标志"^*?",用于调查出品程序重复打单的故障

2009.04.15版本:7.6.355*
1.更新:全部更新了套餐明细项目的处理和统计方法.
2.更新:报表查询添加了"营业综合报表",以后前台收银只需要打印此报表即可
3.更新:报表查询之新的报表把报表打印格式配置文件保存在"\报表格式"文件夹

2009.02.13版本:7.6.354
1.更新:完善了专业预定模块的预定查询\显示\来电记录处理\预定客户处理的功能,不再无限制产生客户记录,防止客户记录过多
2.更新:国宇版PDA基站程序延迟了启动连接数据库的等待时间

2009.02.03版本:7.6.353
1.更新:服务器添加了启动调试模式的功能
2.更新:服务器添加了现场日志显示和保存的功能
3.修正:解决了新版预定模块退出程序时出现非法操作的BUG
4.修正:解决了自动配置模块中不能正确设置自动启动更新的BUG[识别注册表操作不成功]

2009.01.23版本:7.6.352
1.修正:前台收银开台时输入的人数在结账时自动变化为默认人数的BUG
2.更新:国宇版基站程序增加了防止在本机启动多个实例导致错误的功能
3.更新:安装包中使用了新版的预定管理模块.

2009.01.22版本:7.6.351
1.修正:前面版本修改导致的餐桌结账界面上刷会员卡会弹出"用户已注销"提示的BUG

2009.01.19版本:7.6.350
1.更新:国宇版PDA点菜增加了套餐点菜功能
2.修正:出品划菜程序中菜品沽清窗口上选择菜品时连续按回车键导致程序退出的BUG

2009.01.18版本:7.6.349
1.更新:餐饮营业报表查询条件中增加了指定餐桌餐区的条件
2.更新:餐饮收银模块中,如果餐桌账单已经打印过,那么在餐桌上显示一个打印机图标

2009.01.17版本:7.6.348
1.更新:会员管理模块去除了部分无用的数据,如积分和有效消费之类
2.修正:新版软件注册方面的一些小BUG

2009.01.10版本:7.6.347
1.更新:国宇版PDA基站程序增加了日志保存功能
2.更新:出品程序增加了菜品快速定位功能
3.更新:收银输单中输入菜品备注时可以直接用鼠标双击,窗体加大

2008.12.31版本:7.6.346
1.更新:国宇版PDA基站程序增加了估清信息反馈
2.更新:国宇版PDA基站程序增加了延时自动登陆数据库功能
3.更新:出品模块增加了启动参数debug,使程序进入调试状态

2008.12.30版本:7.6.345
1.更新:重写了国宇PDA基站程序接口,实现了:全缓,全催,临时菜
2.更新:收银模块增加了本地打印餐桌详单的功能

2008.12.21版本:7.5.344
1.修正:修正了7.0版本注册方式的一些问题,让网络注册更可靠.
2.更新:加强了组件的事件显示功能

2008.11.22版本:7.5.343
1.修正:修正了近期修改导致的修改账单里面不能正确显示新输入菜品的资料的BUG

2008.11.20版本:7.5.342
1.修正:修正了前期修改导致的餐桌菜品消息不完全同步的BUG

2008.11.17版本:7.5.341
1.修正:最近修改导致的不能正确显示餐桌菜品的小BUG

2008.11.16版本:7.5.340
1.更新:BASELIB库开始支持8.0格式的客户端,将旧的用户权限处理推出到应用程序端执行
2.更新:软件注册方面一个小BUG(For瑞安舍得坊测试)

2008.10.19版本:7.4.339
1.更新:增加了杭州达华兼容明华版IC卡读卡器接口

2008.10.12版本:7.4.338
1.更新:数据中心菜品类别资料编辑可以直接修改其下一个菜品编号ID了
OK 1.会员查找无法查找带有字母的会员编号。
OK 2.新建会员时输入卡号要自动弹出已有会员信息,如有相同信息要有提示操作修改或者覆盖
OK 3.指定分类上面如果选择了会员再切换到其他类别比如签约会员时要先选择全部才能在选择其他类别.
OK 4.要显示最后一次操作工号信息
OK 5.新建会员时选择分类后VIP资料的折扣率要自动选好,VIP资料里的折扣率只有管理员ADMIN才能修改,普通工号不能修改
OK 6.新建会员里的基本信息要添加一个操作人员工号,或者自动显示添加人员工号,QQ号码选项可以取消.
OK 7.预定系统要跟前台下单收银系统关联.
OK 8.报表里要显示每日服务员点菜数量.不包括退菜
OK 9.数据管理里面的搜索功能不行.
OK 10.会员管理显示信息没有显示打折信息
11.报表里退菜原因上要显示下单时间跟出品(退菜时间)这样好记录菜品出品时间长短

2008.10.03版本:7.3.337
1.修正:新版修改导致的数据中心里面出品部门不能正确添加的BUG
2.更新:出品程序打印小票中添加了连桌打印小票时,还可以分类别连小单
3.更新:出品程序打印连桌分单小票的同时可以在另外一台打印机上打印一桌总单
4.更新:出品程序主界面上增加了"菜品沽清"管理窗口,以前的菜品禁用改名为"沽清"

2008.09.29版本:7.2.336
1.更新:收银模块添加了预定餐桌状态同步的选项(FOR SHEDEFANG)
2.修正:旧版本的预定模块临时适应新版本的数据选项(新版本即将未推出)

2008.09.16版本:7.2.335
1.修正:前面版本修改导致的客户端不能保存注册信息的BUG
2.修正:有些时候结账刷会员卡或者刷权限卡时提示"刷卡嵌套太多"的BUG

2008.09.11版本:7.2.334
1.修正:多线程读取远程会员数据库遭遇程序强制退出时出现的非法操作
2.更新:前台收银结账界面上,刷卡以及挂帐窗口的显示速度大幅提高

2008.09.09版本:7.2.333
1.更新:会员管理界面上数据同步更迅速

2008.09.03版本:7.2.332
1.修正:前段时间修改导致的新版本不能正确显示旧版本数据库的菜品的BUG

2008.09.02版本:7.2.331
1.重大更新:出品程序的出品部门设置里面修改为两级管理模式[出品部门]->[打印机],实现了同一部门的产品(如酒水),能自动根据所属餐区分单到不同打印机的功能(解决一些酒店存在多个酒水吧台的问题)

2008.08.29版本:7.1.330
1.修正:服务器同步的一个小问题
2.更新:彻底去除了出品程序的选项设置的旧的界面

2008.08.28版本:7.1.329
1.修正:数据中心修改餐桌资料会覆盖餐桌当前状态的BUG
2.更新:数据中心显示餐桌列表的格式

2008.08.22版本:7.1.328
1.重大更新:所有模块更换了新版注册器,支持服务器单独注册,日期限制等等诸多功能

2008.08.07版本:7.0.327
1.更新:出品程序的打印机选项重新设计,采用了更直观的方式
2.更新:出品程序的菜品列表支持时间提醒,超过20分钟了的菜品以红色字体显示

2008.07.19版本:7.0.326
1.修正:前段时间修改的菜品自动给编号的处理方法,保证正确的给出编号[适宜类别内部编号长度在3位长度内]
2.更新:出品程序去掉了常规选项[是否自动出品],因为每个选择的部门已经有此选项.

2008.07.17版本:7.0.325
1.更新:收银模块增加选项[启用会员卡密码键盘],会员卡密码可以只能由专用密码键盘输入,无法由收银员通过键盘输入
2.更新:会员资料添加属性[不允许保存账单],将会员卡扩展成折扣计算卡[在收银员无权打折的情况下通过折扣卡计算折扣后的金额]
3.更新:重新改进串口刷卡器信息接受顺序,理顺了刷卡接收的逻辑关系.
4.更新:前台收银增加了直接用密码键盘修改会员密码的功能[无法通过普通键盘操作!]
5.更新:收银台自动登记客户资料时,默认选择第一种客户类别
6.更新:收银台刷客户卡时自动更新最新客户资料,并且采用客户所属类别的最新折扣设置情况(如果有指定客户类别的情况)

2008.07.10版本:7.0.324
1.更新:出品程序在服务器上可以显示当前所选择的出品部门了

2008.07.05版本:7.0.323
1.更新：餐饮账单可以打印会员充值卡扣款记录
2.修正：前面修改导致的Config.exe不能自动启动客户端的BUG

2008.07.02版本:7.0.322
1.更新:数据中心改进了用户操作好感度,操作的数据立即更新

2008.06.30版本:7.0.321
1.重大更新:菜品编号采用类别码加菜品码的形式,防止老版本的菜品自动编号和手工编号导致冲突的问题
2.重大更新:会员管理提了出来作为单独的模块销售,餐饮标准版中不再包括会员管理模块,只是在数据中心里面有客户管理.会员管理模块的界面和流程也做了很大的修改.包括:1.界面分成了3个[会员][充值记录][消费记录].2充值时可以选择是否打印回执单,以及打印到哪个打印机(目前小票格式设计器还没做,是固定格式的)
3.更新:高级数据中心恢复了客户编辑的功能
4.更新:高级数据中心选项里面,在常规页面下添加了设置菜品代码长度和类别代码长度的功能.

2008.06.28版本:6.1.320
1.重大修正:在结账时选择多个餐桌结账,会导致后续报表产生错误的数据[导致菜品销售数据加倍].

2008.06.17版本:6.1.319
1.更新:会员管理里面的快速查找功能增加了搜索会员单位名称和电话号码的功能

2008.06.06 - 2008.06.07版本:6.1.318
1.更新:报表查询里面的数据导出和自动数据导出工具(ED)里面的数据导出部分算法做了优化,对于目标数据库不启动事物,直接覆盖完成.且两者工作代码完全统一.
2.更新:账单设计器增加了[使用小票打印机]项目,当使用小票打印机且使用80*60账单模板时应该将该项目的"标题值"项目设置为"是",即可实现菜品资料的连续打印,并且在菜品资料打印完毕,费用项目开始打印之前空一行(应客户要求修改).用连续打印的原因是因为小票打印机无需设置分页,一般会打多少内容走多少纸.

2008.05.12版本:6.1.317
1.更新:报表查询程序的菜品销售报表添加了指定下单员工号的功能.

2008.04.06版本:6.1.316
1.重大更新:取消了HySetup.exe程序,Config.exe配置程序增强了功能,包括(默认不不设置为自动启动,另外增加了管理Windows自动登录的功能)

2008.03.08版本:6.0.315
1.更新:数据中心初始化业务数据的功能增加了批量删除菜品的功能
2.修正:上个更新导致的无法删除菜品类别的BUG

2008.03.07版本:6.0.314
1.更新:可以根据权限删除已经被使用的菜品了(会保留日志,并且不影响报表)
2.更新:用户权限管理暂时恢复到旧版本模式.

2008.03.06版本:6.0.313
1.更新:非系统管理员工号登录系统不允许修改菜品名称

2008.02.17版本:6.0.312
1.修正:餐饮收银模块中,修改菜品数量可能导致数量改为小于0的BUG
2.更新:会员管理界面修改为添加了导航条,修改了显示样式等等.
3.更新:前台收银中如果某张餐桌存在数量为0的菜品(如海鲜)那么进入结账时会提示.

2008.01.23版本:6.0.311
1.修正:默认无需启用IC卡付款方式.

2008.01.21版本:6.0.310
1.修正:出品程序多重启动实例的BUG,防止2003服务器上因为多个用户登录导致的重单打印问题.

2008.01.20版本:6.0.309
1.重大更新:服务器添加了附加插件功能,可以完成一些附加的后台功能,插件放在HH\Plus目录
2.更新:前台收银中,结账时如果还有数量为0的菜品,禁止结账.
3.修正:修正了IC卡充值消费管理模块的一些错误和不足,并提供了详细的联机手册.

2008.01.19版本:6.0.308
1.更新:主版本号直接提升到6.0
2.更新:服务器去掉了自动更新数据库的功能(因为服务器不管理具体的数据库),大大加快了启动速度,可能导致MAKEDISH无需延迟启动了

2008.01.18版本:4.5.308
1.重大更新:IC卡读写模块提炼出来作为外部库被调用,所有配置接口放在安装目录下面ICCard子目录

2008.01.11版本:4.4.307
1.更新:注册模式第二次变更
2.更新:库存模块初步集成
3.更新:联机手册模式变更
4.更新:出品程序选项界面重大变化(取消了老式的打印服务器模式选项)
5.更新:前台收银模块选项作了重大变化,可以更加方便的管理磁卡刷卡器
6.更新:前台收银模块增加了VOD支持模块(先支持老帝皇VOD产品,测试中)

2007.12.15版本:4.4.306
1.重大修正:无盘网络中加密狗模式下软件注册信息可能失败的BUG.

2007.12.13版本:4.4.305
1.修正:最近修改导致的代理打印账单时不能正确打印菜品明细的BUG(当时此修改的初衷是为了提高账单保存效率,详见源程序备注)
2.更新:自动出品程序启动时检查默认的出品工号888密码为888

2007.12.10版本:4.4.304
1.更新:账单打印添加了打印次数项目
2.修正:报表查询中菜品销售排行选择类别过滤时的语法错误

2007.12.01版本:4.4.303
1.更新:会员管理添加了生日提醒功能,显示最近一周内过生日的会员资料

2007.11.30版本:4.4.302
1.更新:菜品销售报表添加了选项"按照销售价格分组",默认是不选择

2007.11.29版本:4.4.301
1.更新:用户表支持同仓库管理的兼容

2007.11.23版本:4.4.300
1.更新:高级数据中心添加了新的接口SaveDish2,可以支持保存菜品类别和单位信息以及拼音,详细资料请查阅Excel宏示例

2007.11.21版本:4.4.299
1.更新:下单模式下,已经被提交的菜品,不再允许被直接取消

2007.11.15版本:4.4.298
1.修正:前台收银对于刷卡的开关控制功能的一个BUG(不能正确表达读卡器的状态)

2007.11.14版本:4.4.297
1.更新:暂时取消了MSGV50的功能,适应服务器上多网卡的情形.
2.更新:小票格式打印账单时,将VIP信息顺延到所有项目最后

2007.11.10版本:4.3.296
1.更新:餐饮收银修改账单界面上添加了可以按照流水号查找账单的功能.

2007.11.07版本:4.3.295
1.修正:账单打印上面的累计积分(不应该包含本次积分)

2007.11.01版本:4.3.294
1.更新:前台收银修改菜品数量和价格的权限重新做了界面效果处理(采用禁用文本框的形式)
2.更新:走廊下单程序采用跟收银一样的注册码
3.修正:前台收银前些版本不能在状态条显示工号的功能

2007.10.24版本:4.3.293
1.更新:数据库管理工具(DBUpdate.exe)界面做了变更(支持Admin模式)

2007.10.22版本:4.3.292
1.更新:结账付款记录自动汇总
2.更新:前台收银登录日期在凌晨后自动归纳于前一个营业日(降低手工变更营业日期的培训难度)

2007.10.10版本:4.3.291
1.更新:数据中心添加了快捷键F2直接修改菜品编号

2007.09.18版本:4.3.290
1.修正:上次修改5秒钟内禁止删除导致的一个删除菜品错误

2007.08.23版本:4.3.289
1.更新:出品程序中,几个权限的限制问题更加明确(按钮禁止用的提示)
2.更新:下单程序中,刚输入5秒中内的菜品禁止执行取消操作(For名欧咖啡)
3.更新:报表导出数据时,账单明细表按照原始顺序排序再导出
4.更新:出品程序添加了隐藏到任务栏的功能

2007.08.10版本:4.3.288
1.更新:餐饮报表查询中菜品销售排行报表的条件设置窗口布局重新设计,增加了选择排序字段的功能
2.更新:餐饮报表查询中营业明细报表中添加了开台时间字段(适应上塘老地方棋牌馆要求)
3.更新:餐饮报表查询中客户资料报表的查询条件设置和显示代码(性能优化)

2007.08.08版本:4.3.287
1.更新:自动升级数据库功能中不能正确识别新版本的小BUG

2007.07.31版本:4.3.286
1.修正:修正了前期版本导致的一个会员积分显示错误

2007.07.21版本:4.3.285
1.更新:针对钟点计费做了个优化,实现精确计费功能(老地方棋牌室)

2007.07.06版本:4.3.284
1.更新:本地添加了自动判断数据库当前版本的功能,并且可以自动升级
2.更新:为了防止客户端无故分离数据库,将DBUPdate.exe添加了启动参数admin

2007.07.05版本:4.2.283
1.修正:账单打印上面分类别小计时把免费掉的金额也小计进去了.
2.更新:输单模式下,已经打印过小票的菜品和设置为已经结账的菜品不允许取消

2007.06.26版本:4.2.282
1.更新:会员添加了密码功能,收银刷会员卡时,如果有密码,就需要会员输入支付密码

2007.06.24版本:4.2.281
1.更新:会员管理的界面进行了大调整,不再区分不同级别的会员显示,会员种类添加了"打折方式"和"折扣率"属性,而且只有Admin才能去修改它,普通操作员不能直接修改会员的打折属性,必须在Admin制定好"会员类别"的打折属性后,选择它使用,而不能自己修改
2.修正:出品程序修正了部分情况下不能自动出品的BUG(前段时间修改造成)
3.修正:客房程序的交接班报表出现查询错误的BUG

2007.06.23版本:4.2.280
1.更新:数据中心添加了新接口"保存会员资料",供Excel调用成批增加会员资料
2.修正:收银结账界面,在普通模式下(未启用一单一买的结账模式)修改菜品数量和价格的判断问题

2007.06.11版本:4.2.279
1.更新:账单打印可以将不同的付款方式打印到不同的位置(以前只能打印在同一行)
2.更新:账单消费明细内容记录的折扣率(便于销售菜品折扣汇总)

2007.06.02版本:4.2.278
1.更新:针对月光码头,增加了一个新权限(仅在启用菜品结账模式下有效)"是否允许在收银台输入菜品"

2007.05.29版本:4.2.277
1.更新:在"输单结账模式"下,如果某张餐桌还有菜品没有标志已经结账,那么就不允许关台(月光码头提出)

2007.05.26版本:4.2.276
1.修正:餐饮报表查询里面作废删除账单只允许Admin执行,没有按照权限判断的BUG

2007.05.22版本:4.2.275
1.更新:出品程序中如果是赠送的菜品则在小票上菜品名称后面打印"[赠送]"字样
2.更新:餐饮收银程序中添加了在主窗口标题栏显示当前酒店名称的功能

2007.05.21版本:4.2.274
1.修正:餐饮报表中的免费菜品汇总和明细报表原先把"已经取消了的免费了的菜品"也统计进去了

2007.05.19版本:4.2.273
1.更新:餐饮报表添加了"取消菜品明细报表"和"取消菜品汇总报表"

2007.05.18版本:4.2.272
1.更新:收银下单模式中,加了个选项,如果不是所有菜品都已经结账的话禁止入帐清台,主要针对一单一买的场所

2007.05.09版本:4.2.271
1.更新:出品程序打印餐桌连单时 末尾加上金额汇总,方便一单一买的营业场所
2.更新:菜品添加了暂停使用的功能,被暂停的菜品将不能再输单,除非解除暂停

2007.04.19版本:4.2.270
1.更新:收银结账的界面上,刷会员卡时采用"会员的指定折扣率"和"当前折扣率"中比较低的折扣率

2007.03.24版本:4.2.269
1.更新:餐饮收银未登录前不显示试用版标志

2007.02.11版本:4.2.268
1.修正:修正了快餐版本的一些同步不及时的问题

2007.02.08版本:4.2.267
1.修正:出品程序中条码枪划菜时串口读取的一个小BUG
2.更新:帐单打印中添加了打印复合项目的功能"$=冷盘+热菜+海鲜",详细使用说明参阅在线帮助
3.更新:收银台免费菜品的功能添加了取消免费菜品的功能

2007.02.04版本:4.2.265
1.更新:营业报表添加了"折扣率"列
2.修正:餐饮收银中对于找零金额的计算BUG

2007.02.03版本:4.2.264
1.更新:无线PDA基站服务器程序添加了功能选择对话框

2007.01.30版本:4.2.263
1.修正:收银中读取账单时,如果碰巧遇到已经被删除的菜品记录时,会当作正确的记录读取的BUG

2007.01.28版本:4.2.262
1.更新:数据中心和前台收银中,添加菜品的界面上增加了根据名称实时过滤的功能,避免建立重复的菜品

2007.01.24版本:4.2.261
1.更新:报表查询中营业报表可以显示和指定会员卡号了

2007.01.09版本:4.2.260
1.更新:账单打印上面一个小计汇总的逻辑问题,关于"先打加菜再打退菜"项目的,在平阳名坊咖啡暴露出来的小问题
2.更新:账单保存最低消费金额的问题

2007.01.01版本:4.2.259
1.修正:会员管理里面刷新会员卡时在弹出的会员编辑框中卡号不显示的BUG

2006.12.31版本:4.2.258
1.修正:菜品的"只有会员卡才允许打折"这个属性不能及时同步的BUG

2006.12.29版本:4.2.257
1.更新:会员管理所有充值项目的权限修改为统一的"是否允许执行会员卡充值",而不再区分是会员卡还是IC卡

2006.12.28版本:4.2.256
1.更新:更新了快速结账版本下的付款方式界面,双重付款方式(现金券和现金)
2.更新:会员管理增加了直接刷卡进入会员资料编辑的界面
3.修正:修改账单中用负数退菜的一个权限判断错误

2006.12.25版本:4.2.255
1.更新:收银结账之快餐模式增加了付款找零的功能.

2006.12.22版本:4.2.254
1.重大更新:会员积分管理的模式发生了重大变化,可以灵活指定积分的核算类别了
2.更新:在收银台双击餐桌时,如果是空的餐桌就弹出开台窗口,如果是在用的餐桌就弹出结账的窗口
3.修正:收银结账中,读取IC卡时,要根据客户资料里面的打折情况进行换算后再扣款.

2006.12.21版本:4.2.253
1.更新:报表查询中登录界面的一些改进,主要是更加准确,更加适应于4.0版本架构
2.更新:报表查询中一些关于OEM方面的内容,便于以后OEM信息的加入

2006.12.20版本:4.2.252
1.更新:收银程序支持直接刷会员充值卡结账(快速结账模式下)
2.更新:收银程序中账单上的实收金额不再包含挂账和免单金额,可以不包含优惠券等(在数据中心付款方式里面进行设置)
3.更新:收银程序中右键快速显示账单时只显示当前日期的账单,过期的账单不再全部显示

2006.12.17版本:4.2.251
1.重大更新:收银程序添加了快速结账模式的支持,F8--快速结账,* -- 快速付款结账

2006.12.15版本:4.1.250
1.修正:收银台呼叫数据中心的权限限制问题
2.修正:数据中心中,新建用户资料的权限问题
3.更新:营业报表中添加了"免费菜品汇总报表"

2006.12.09版本:4.1.249
1.修正:前段时间为关松楼修改的会员积分管理的一个自动积分返点导致的错误

2006.12.08版本:4.1.248
1.修正:修正了报表查询里面一个隐藏的溢出的BUG(统计待导出的账单的条数时)

2006.12.04版本:4.1.247
1.修正:自动登录会员管理和数据中心的权限限制

2006.11.30版本:4.0.246
1.修正:4.0服务器的网络信息同步的一个小BUG
2.修正:4.0各个工作站网络信息同步的一个小BUG
3.更新:预定程序预定报表添加了导出到Excel功能

2006.11.28版本:4.0.245
1.更新:报表查询模块正式开始完全支持4.0版的服务器
2.更新:修改了收银程序的一些默认选项值
3.更新:报表程序里面营业报表从显示餐桌名称转换为显示餐桌编号
4.更新:修改了报表程序登录的流程

2006.11.26版本:4.0.244
1.重大更新:服务器自带了SQL Server管理器功能,完全统一了客户端配置方式

2006.11.22版本:3.33.243
1.修正:账单设计器中"小计标题靠右边"项目有时设置会无效
2.更新:账单打印中,在小票模式下,可以在所有项目打印完毕后,再隔两行后打印备注如"好易软件 谢谢使用",促使打印机多走纸
3.更新:账单打印添加了,收款金额,找零金额
4.更新:付款明细的打印处理进行了更新,小票打印模式做了优化

2006.11.21版本:3.33.242
1.更新:预定程序添加了"占位/取消"功能
2.更新:IC卡刷卡会员管理模块加强了管理功能
3.更新:会员管理界面针对选项做了调整
4.更新:会员管理中取消了"高级会员"级别,目前只使用"限制""普通""会员"三个级别
5.更新:会员管理中数据长度做了部分限制,不允许超过默认的长度(编号,姓名,密码等等)
6.更新:新版图形显示接口启用了带预定的图标,文件名为hispic40_yd.bmp
7.更新:自动更新包可以全自动更新服务器了(强制服务器退出并且完成后再启动服务器,更新操作更傻瓜化)

2006.11.16版本:3.33.241
1.更新:会员管理中IC卡充值界面不允许直接修改卡上余额了,必须采用增加或者减少的方式进行修改(会留下记录)
2.更新:会员资料添加了挂失和取消挂失的功能(在会员管理里面)

2006.11.15版本:3.33.240
1.更新:收银改单中付款方式中IC卡付款项目禁止退款
2.更新:餐饮系统添加了日志功能,日志内容保存在服务器D:\HH\LOG目录

2006.11.13版本:3.33.239
1.更新:服务器上只设置了一个IP地址的话才动态更新设置
2.重大更新:餐饮系统各个桌面开始支持动态的状态图(\Pic\hispic40.bmp)
3.更新:高级数据中心添加了一个新高级选项"台面上显示餐桌名"

2006.11.11版本:3.32.238
1.更新:餐饮账单打印添加了自定义项目"一定要打印横线",其含义见相关手册
2.重大更新:服务器添加了自动变更配置项目里面的数据库IP地址的功能,要求必须跟数据库安装在同一台电脑上,并且服务器只能有唯一有效的IP地址,对于多穴主机可能导致工作站连接失败.

2006.11.10版本:3.32.237
1.更新:服务器上添加了USB加密狗注册功能
2.更新:餐饮收银相应客户端也针对加密狗注册功能进行了更新
3.更新:餐饮收银工具菜单添加了"计算器"功能

2006.11.06版本:3.31.236
1.更新:出品程序在服务器端选择自动更新后退出时不再要求输入Admin密码了
2.更新:出品程序的自动登录功能能马上自动反馈登录信息给服务器了
3.更新:报表程序中营业明细报表添加了桌数合计和实收合计(即实收加挂帐)

2006.11.05版本:3.31.235
1.更新:在只允许下单台退菜的模式下也允许退套餐了,但是不处理退套餐的明细
2.更新:好易客户端配置工具(Config.exe)正式开始支持2.0版的服务器

2006.11.3版本:3.31.234
1.修正:彻底修正了在划菜口显示某桌菜品后导致的重复打单的问题
2.更新:钟点消费项目添加了个"不汇总数量与金额"的属性,其功能请阅读说明书
3.更新:餐饮输单菜品列表框顺便显示部分了

2006.11.2版本:3.31.233
1.修正:划菜程序中显示指定餐桌菜品时导致重复打印单子的BUG
2.更新:已经出品的菜品也允许重打(有重打标志)
3.更新:报表支持远程注册了

2006.10.26版本:3.31.232
1.修正:解决了收银台在合并显示菜品的模式下可能会翻番的显示菜品数量的问题
2.更新:在合并模式下有些对菜品的操作被禁止
3.更新:非正常退出结账状态不再保留结账标志
4.更新:收银台添加了将某个台位部分菜品转移到别的台位的功能(有权限控制)
5.修正:出品台程序在连单打印的情况下,偶尔会重复打印某条菜品或者漏打一些菜品的BUG
6.更新:新版服务器远程配置工作站项目中根据服务器设定做决定,不再强制同步

2006.10.25版本:3.31.231
1.更新:收银台中修改菜品数量功能里面,如果不是Admin登录则禁止修改菜品价格(重要),修改数量则要看当前用户的权限

2006.10.23版本:3.31.230
1.更新:报表程序添加了"营业对帐"报表,针对菜品类别进行分类汇总.
2.更新:收银程序输单时,如果想输入数量为0的菜品,那么数量框必须填写0,否则无效
3.更新:工作站的设置通过服务器发送信息确认,减少工作站配置项目,以后只需指定IP和相应端口就可以了
4.更新:服务器重新写了一遍,支持多服务器系统

2006.10.11版本:3.30.229
1.更新:彻底更新了开台/关台的快捷键问题
2.更新:点菜窗口上菜品选择框的布局问题(宽度完全跟随窗体变化)
3.修正:新版注册方面的一些同步问题,跟以前版本不再兼容

2006.10.10版本:3.30.228
1.更新:前台收银的点菜界面上添加了开台/关台的快捷键
2.更新:前台收银添加了记录上次运行时点菜框宽度的功能,方便操作

2006.10.07版本:3.30.227
1.更新:注册记录保存到数据库,防止丢失
2.更新:前台收银的未买单统计界面(改为列表形式)
3.更新:会员使用会员价的功能在客户属性里面设置
4.更新:添加了软件反注册功能的测试版
5.更新:收银程序在下单模式下具备原先下单程序的一些特性,如:在F4关闭了点菜界面后按下Esc键可以注销登录,还有无动作计时登录

2006.10.04版本:3.30.226
1.更新:修改了餐饮报表程序导出数据的文件名后缀,改为"hbb",并且在安装程序中指定了文件类型关联

2006.09.28版本:3.29.225
1.修正:报表查询程序对Access支持的一个小BUG

2006.09.23版本:3.29.224
1.更新:扩展了打印机类的开始打印文档和结束打印文档时对纸张处理的问题,基本解决了兼容所有型号打印机的问题
2.更新:收银主界面添加了菜单呼叫账单设计器

2006.09.22版本:3.28.223
1.更新:高级数据中心里面初始化业务数据的项目更合理

2006.09.12版本:3.28.222
1.更新:出品程序添加了某个部门拒绝退菜单的选项

2006.09.09版本:3.28.221
1.修正:报表查询程序中,导出数据不能正确导出时间的BUG
2.更新:自动数据导出功能中的数据集中导出功能
3.修正:PDA基站程序中无法传递口味做法的BUG

2006.09.04版本:3.28.220
1.更新:添加了是否允许进入结账界面的权限(以供将收银统一当做下单用)

2006.09.02版本:3.28.219
1.修正:报表查询中菜牌报表如果进行了设置的话会无法显示报表的错误.(字段排列问题)

2006.08.17版本:3.28.218
1.更新:收银结账打印模块采用了新版的打印模块
2.更新:出品划菜程序选项中应舍得坊的要求添加了拒绝出品的餐区
3.更新:晚上统一了所有的打印模块(最后一个是出品程序,通过了测试)

2006.08.11版本:3.27.217
1.修正:在为舍得坊小南店修改实时导出数据的工具时,顺便解决了报表中一个不能正确拷贝账单餐桌明细记录的BUG

2006.08.10版本:3.27.216
1.更新:报表菜牌报表添加了出品部门列

2006.08.09版本:3.27.215
1.修正:前台收银结账单打印同报表纸型冲突的问题得以解决
2.修正:前台收银F9打印时提示语有个错别字的问题
3.更新:数据中心和报表里面显示所有菜品的报表中可以显示会员价列了
4.更新:重新修正了试用版功能限制方式

2006.08.07版本:3.27.214
1.更新:出品划菜程序中暂停必须要Admin才能纸型了,防止操作员误暂停

2006.08.05版本:3.27.213
1.修正:在测试21点后价格变化的问题时,顺便修正了换台不能延续开台时间的BUG

2006.08.04版本:3.27.212
1.更新:出品程序添加了某些部门产品按照餐区分别出单的功能(部门和打印机名称里面带"_"代表需要分单的)
2.更新:专门为舍得坊推出了21点以后开台用不同的菜品价格的功能

2006.07.29版本:3.27.211
1.更新:前台收银添加修改菜品资料采用刷卡确认权限

2006.07.25版本:3.27.210
1.更新:收银台在下单模式可以输入数量为0的菜品了(主要解决海鲜类的斤两问题,有提示)

2006.07.24版本:3.27.209
1.修正:数据中心显示用户列表不能正确显示岗位列的BUG
2.更新:无线PDA基站采用新版本接口程序

2006.07.21版本:3.27.208
1.更新:原版收银添加了修改(删除,重打)结账单支持经理刷卡授权的功能
2.更新:报表查询之导出数据做了重大更新,采取了包括临时文件加快读写速度和自动压缩数据库文件等措施来优化性能

2006.07.20版本:3.27.207
1.更新:在原先收银V2.9的基础上修改出了简易型的娱乐(羽毛球馆)收银软件

2006.07.16版本:3.27.206
1.更新:收银程序中取消菜品后"下单人"名称用新的工号变更

2006.07.13版本:3.27.205
1.更新:收银程序在特殊模式下处理付款方式的问题(直接输入退单的模式,应:瑞安钟锦记)
2.更新:出品程序可以在选项里面设定显示处理退菜单问题

2006.07.08版本:3.27.204
1.修正:收银模块登录系统会报告错误的客户端类型的问题(此问题是前些日子增加自动登录功能造成)
2.更新:PDA基站程序重新写了一个版本,便于调试

2006.07.07版本:3.27.203
1.更新:餐桌明细索引ID每次自动从1开始(重大更新)
2.更新:高级数据中心增加了新建和删除的快捷键
3.更新:用户添加了职务字段(非PDA点菜员不再往PDA上传)

2006.07.06版本:3.27.202
1.更新:出品程序添加了重打标志
2.更新:出品程序ESC键添加了切换焦点的作用
3.更新:出品程序添加了时钟显示
4.修正:收银程序数量为0也允许输入的BUG(影响出品台)

2006.07.05版本:3.27.201
1.更新:出品划菜程序支持串口条码枪了
2.更新:针对北洋2002CP热敏打印机做了兼容性测试,OK
3.更新:PDA点菜和出品划菜添加了叫起菜功能
4.更新:重新调整了标准出品单打印格式
5.更新:无线基站程序和出品划菜程序添加了退出需要Admin确认密码的功能,防止非法退出程序
6.更新:重新确认了无线点菜的做法附加条件,以及附加条件的打印格式"/"

2006.07.03版本:3.27.200
1.修正:报表导出数据不再被MDB数据库的文本字段的不允许空属性所阻断了

2006.07.02版本:3.27.199
1.更新:无线基站操作不再等待

2006.06.30版本:3.27.198
1.更新:出品程序添加了快捷键选择某张餐桌,并且只显示该餐桌的所有本部门菜品(便于划菜用)

2006.06.29版本:3.27.197
1.更新:收银台添加了打印餐桌详单的功能
2.更新:收银台提交餐桌菜品添加了Ctrl+回车键的快捷键
3.更新:收银台如果是下单状态,如果菜品已经被接受打印或者已经完成 则禁止取消了

2006.06.28版本:3.27.196
1.更新:PDA点菜添加了打印详单指令(用备注为AAAA的菜品,其名称为打印机名称)
2.更新:PDA点菜添加了基站数据更新指令(同上BBBB)
3.更新:PDA点菜添加了基站无线下载指令(同上CCCC)
4.更新:重写了出品程序的详单打印模块

2006.06.20版本:3.27.195
1.修正:新版本包厢费结账时默认不自动选中的BUG

2006.06.19版本:3.27.194
1.重大更新:出品程序完全支持条形码划菜了
2.更新:出品程序支持助记符查询菜品

2006.06.17版本:3.27.193
1.更新:出品程序添加了按照索引划菜
2.更新:出品程序添加了按照菜品名和助记符过滤显示菜品
3.更新:出品程序添加了菜品显示名称列附加显示索引ID的功能
4.更新:出品程序添加了制作单打印索引ID(便于划菜)的功能,条码打印待增加
5.更新:高级数据中心之清空业务数据添加了附加的把点菜表索引清空(ID重置为0)的功能

2006.06.16版本:3.27.192
1.更新:餐饮收银和报表将折扣额分成了折扣和去零头两个部分(待测试)
2.更新:无线点菜基站,增加了"全缓"功能,新版本接口待测试完善

2006.06.11版本:3.27.191
1.更新:餐饮账单打印时,如果是先打印加菜再打退菜,如果没有退菜的话就不再打印横线

2006.06.10版本:3.27.190
1.修正:修正了出品台在联机添加了新菜品后,该新菜品打印部门可能不正确的BUG
2.更新:出品台打印菜品制作单时可以选择不打印价格数字了(舍得坊)
3.修正:收银台输入菜品时,选择备注时不弹出所有可选备注项目的BUG
4.修正:收银台输入菜品时,不自动弹出备注框的问题(指定了可选备注后)
5.更新:强制指定菜品备注添加了快捷键Ctrl
6.更新:菜品输入时的备注选择框上添加了Ctrl(确认)快捷键,将删除备注快捷键修改为Del键

2006.06.09版本:3.27.189
1.更新:餐饮收银前台添加了直接修改菜品数量和价格功能(适应海鲜类先输单再定数量的模式)

2006.06.07版本:3.27.188
1.更新:报表程序打开时不再直接打开数据库读取用户名(防止服务器不通导致失去响应)

2006.06.06版本:3.27.187
1.更新:出品程序部门选择选项保存到注册表里面,不再保存在数据库(日后需要注意考虑还原卡)
2.更新:收银台添加"未买单台位统计"项目(从下单台引进)

2006.06.03版本:3.27.186
1.修正:报表查询导出的数据库的免费菜品的一个小错误

2006.06.01版本:3.27.185
1.更新:添加了结账时零头取舍方式选择的功能(只入不舍,四舍五入,只舍不入)

2006.05.30版本:3.27.184
1.更新:收银结账包厢费临时保存的小功能

2006.05.27版本:3.27.183
1.更新:为了溢香厅老店的兼容性重新调整了账单打印的费用跟进功能

2006.05.25版本:3.27.183
1.更新:收银重新调整了账单打印的纸张管理功能,基本做到同报表打印纸张不冲突

2006.05.21版本:3.26.182
1.更新:重新调整了结账时向上取整的功能
2.更新:服务器添加了退出时备份*.dat配置文件的功能

2006.05.20版本:3.26.181
1.更新:餐饮收银添加了限制收银员查询往日结账单的权限

2006.05.19版本:3.26.180
1.更新:重新整理了结账时四舍五入问题(可能解决了前段时间客户[王府]反映的多收1块,少收1块的问题)

2006.05.15版本:3.26.179
1.更新:餐饮收银添加了选择餐区显示的功能(选项设置)
2.更新:餐饮出品重新打印菜品出品单添加了权限限制

2006.05.13版本:3.25.178
1.更新:数据库组件对SQL Server之nvarchar类型的识别问题,解决了有时不能自动更新数据库的BUG

2006.05.07版本:3.24.177
1.更新:网络注册功能作了极大修改,简化了注册步骤

2006.05.06版本:3.23.176
1.更新:收银结账修改结账单界面上增加了直接打印选中的账单的按钮

2006.05.04版本:3.23.175
1.更新:餐饮营业汇总报表添加了按照开始日期和结束日期过滤的功能
2.修正:前段时间添加的钟点计费功能,不计算小时数的BUG

2006.04.29版本:3.23.174
1.更新:完善了高级数据中心之客户资料管理功能
2.更新:餐饮报表营业报表查询添加了按照结账时间过滤的功能

2006.04.28版本:3.23.173
1.修正:下单台开台时人数和开台时间不能正确传递和保存的BUG

2006.04.27版本:3.23.172
1.修正:数据中心修改餐段后的开始时间显示有错误
2.更新:高级数据中心重新编写了餐段编辑窗口
3.更新:收银程序状态条上的运行模式栏目可以显示"钟点计费"和"普通模式"了
4.更新:标准模式下买单后不再显示钱袋图标了(默认)
5.更新:更加完善了服务器集中注册模式

2006.04.26版本:3.23.171
1.修正:上一个版本(钟点计费)导致的收银台"显示开台时间"无效的BUG

2006.04.25版本:3.23.170
1.更新:更新了远程注册的功能

2006.04.24版本:3.23.169
1.更新:完善了服务器跟客户端交流信息的渠道

2006.04.21版本:3.22.168
1.更新:餐饮收银添加了新版钟点计费功能

2006.04.20版本:3.22.167
1.更新:餐饮账单打印设置为每个页面都打印"酒店名称"等项目(原先只在末页打印的)

2006.04.19版本:3.22.166
1.更新:数据中心添加了新的接口SaveDish1,用于脚本语言保存菜品资料
2.更新:收银账单打印取消了在桌号后面打印备注的功能.

2006.04.18版本:3.22.165
1.更新:餐饮收银结账时"挂帐"和"免单"的结账方式重新可以直接选择客户了,无需再像前些版本必须刷会员卡了
2.更新:高级数据中心的新版的数据库业务数据初始化功能
3.更新:高级数据中心作为今后统一的数据中心程序,具备按照模块自动选择显示项目的能力

2006.04.17版本:3.22.164
1.更新:高级数据中心的导航栏重新调整样式
2.更新:添加了"钟点消费"项目,管理诸如棋牌,足浴,按摩类钟点计费项目

2006.04.15版本:3.21.163
1.更新:安装程序中文化,并且设置了关键文件(.dat)不覆盖的措施,适合用户重装系统类
2.更新:设置了软件的标准运行模式(不允许修改核算付款方式等信息),方便用户使用预设的报表格式
3.更新:默认账单格式为小票打印机样式

2006.04.14版本:3.21.162
1.更新:工作站端添加了服务器版本验证功能,为后续版本升级做铺垫
2.修正:餐饮收银部分在餐桌上右键选择显示账单时,不再显示已经删除了的账单

2006.04.04版本:3.20.161
1.更新:餐饮收银报表添加了新的报表,菜品销售明细报表,可以查询任意菜品一段时间以来的明细销售记录,不汇总显示

2006.04.03版本:3.20.160
1.更新:收银台添加了新的权限,是否允许用负数退菜(同F12退菜的权限进行了分离)

2006.04.01版本:3.20.159
1.修正:换台(合并餐桌菜品)时有可能会丢失账单号的一个BUG
2.更新:添加了新的权限(是否允许合并已经保存过的账单)

2006.03.31版本:3.20.158
1.更新:好易服务器添加了启动参数"auto"
2.更新:餐饮报表添加了菜品销售按照类别的汇总报表(包含折扣额和免单额)

2006.03.28版本:3.20.157
1.更新:收银结账时去零头加了权限限制
2.更新:收银结账时去零头的权限可以通过刷经理卡验证
3.更新:输单界面F8时价功能可以通过刷经理卡验证权限

2006.03.27版本:3.19.156
1.重大更新:用户权限管理界面做了统一调整,另外程序内部权限管理的逻辑完全自由化,在兼容以前程序的前提下,实现了任意顺序显示权限记录的功能(前提是每个权限的内部ID永远保持不变),最终极限达到了250种权限,基本可以兼容2-3年内软件功能和产品扩充的需求

2006.03.25版本:3.18.155
1.重大更新:挂帐和免单转变为普通的付款方式了,跟以前的处理方法不一样了,相应的报表格式也变化了

2006.03.22版本:3.17.154
1.更新:餐饮账单设计器里面去掉了"应收金额"项目

2006.03.17版本:3.17.153
1.更新:所有收银模块的用户登录界面做成了统一样式
2.更新:营业汇总报表添加了选项(不区分餐段)
3.修正:餐饮报表里面销售排行里面包含了已经删除的账单的内容

2006.03.16版本:3.17.152
1.更新:收银结账添加了Ctrl+F9快捷键打印账单时不打印付款明细,Shift+F9只打印当前账单的付款明细功能

2006.03.14版本:3.17.151
1.更新:收银结账时,可以输入客户手机号调出客人资料

2006.03.13版本:3.17.150
1.更新:菜品添加了只有出示会员卡才允许打折的功能(迎合某些特殊客户的要求)

2006.03.11版本:3.17.149
1.更新:餐饮收银添加了经理卡打折授权卡刷卡功能(买单时刷相应的经理卡可以打不同的折扣)
2.更新:收银员权限中添加了可以使用的最低折扣率的功能
3.更新:收银里面套餐明细自动生成时添加了按照位数来确定明细数量的功能
4.更新:收银结账那里添加了打印发票金额的功能(输入发票金额的功能先前已经具备),账单格式,报表里面相应做了更新

2006.03.08版本:3.16.148
1.更新:添加了销号管理模块
2.更新:报表添加了菜品报表条件设置按照备注查询的功能

2006.03.06版本:3.15.147
1.修正:修正了在下单台上任意权限的用户都可以修改下单菜品价格的BUG

2006.02.26版本:3.15.146
1.更新:餐饮收银添加了修改账单界面上的免费菜品的快捷键
2.修正:餐饮收银界面上改正了最近版本出现的免费菜品不能再次打印出免字的BUG

2006.02.24版本:3.15.145
1.更新:报表设计器恢复了以前的纵横打印功能

2006.02.23版本:3.15.144
1.更新:餐饮报表查询中的营业曲线添加了显示项目设置,直接打印,界面调整等功能
2.更新:营业汇总报表中添加了消费汇总列
3.修正:安装包中添加了对图表控件的引用

2006.01.20版本:3.15.143
1.修正:今天花了6个小时解决新版报表打印设计器和账单设计器的走纸控制和方向的问题,取得初步效果,由于测试打印机的故障,浪费了不少时间

2005.12.25版本:3.15.142
1.更新:出品单上菜品单位放在了数量和价格中间

2005.12.20版本:3.15.141
1.更新:打印组件实现了选择打印机的功能
2.更新:出品程序添加了补单打印的功能
3.更新:出品程序增加了设置为打印服务器模式的功能

2005.12.13版本:3.14.140
1.更新:收银免费菜品可以设置需要指定授权人

2005.11.30版本:3.14.139
1.更新:收银程序仿照下单在状态条添加了台位数统计

2005.11.29版本:3.14.138
1.更新:交接班增加了直接横向打印报表的功能(For天一角)
2.更新:收银台菜品列表添加了显示下单人的列
3.更新:收银台餐桌图标添加了开台时间的显示

2005.11.07版本:3.13.137
1.更新:添加了会员积分返点的付款方式(测试版)
2.更新:在新版本中完美的解决了五马老版本的分类汇总排序合计金额的功能,从此可以完全放心的对五马三家店软件进行升级为新版本了
3.更新:修改了账单设计器小计项目(承上)响应的账单打印模块和收银模块的打印部分重新添加了功能

2005.10.24版本:3.12.136
1.更新:会员管理添加了导出数据到Excel功能(会员资料和积分记录)
2.更新:添加了权限(允许修改全部账单)

2005.10.23版本:3.11.135
1.修正:修正了在修改账单中某种情况下打印账单时,菜品记录会重叠覆盖的情况
2.更新:添加了免单和挂帐的权限检查功能

2005.10.17版本:3.11.134
1.更新:预定管理中新建预定窗口弹出全空白

2005.10.16版本:3.11.133
1.更新:预定管理中预定视图添加了快捷菜单
2.更新:预定管理添加了Insert快捷健新建预定
3.更新:预定管理中预定窗口关闭时会提示保存
4.更新:同一张餐桌重复预定时会有提示信息(以前无提示只有默认拒绝,让用户无法理解)
5.更新:预定管理中客户的个性资料直接显示在预定登记窗口上
6.更新:预定管理中客户资料直接更新

2005.10.15版本:3.11.132
1.更新:预定添加了高级查询功能
2.更新:预定客户资料指定只能编辑第一级别,客户级别管理
3.更新:预定管理添加权限控制

2005.10.14版本:3.11.132
1.更新:重写了报表数据导出到Excel的功能(采用Excel组件库接口完成)

2005.10.13版本:3.11.131
1.更新:收银账单中,如果未收包厢费则包厢费项目打印0,另外包厢费是否收取不再合计到折扣额中

2005.10.11
1.更新:结账单代理打印由客户端指定代理打印服务器的计算机名,解决大型酒店多台代理打印服务器的分工问题

2005.10.08版本:3.11.130
1.更新:报表查询中营业明细报表添加按照餐桌编号或者餐桌名称选择的功能

2005.10.07版本:3.11.129
1.更新:报表查询添加了退菜明细报表
2.更新:报表查询添加了退菜汇总排行报表
3.更新:报表查询添加了免费菜品明细报表

2005.10.05版本:3.11.128
1.修正:报表查询中餐桌菜品消费明细不能打印预览的BUG
2.更新:报表查询菜品销售报表可以同时选择多个餐区
3.更新:报表查询菜品销售报表可以选定显示退菜报表
4.更新:添加了"只允许在下单台退菜"的功能

2005.10.03版本:3.11.127
1.更新:收银买单如果没有刷会员卡就不打印会员积分项目在收银单上

2005.10.01版本:3.11.126
1.更新:恢复直接修改菜品编号的功能

2005.09.30版本:3.11.126
1.更新:重新更新了账单打印的分类打印菜品的控制

2005.09.16版本:3.11.125
1.更新:发布新版HHPrinter.dll

2005.09.14版本:3.11.124
1.更新:支持酒吧模式(Beta1)
2.更新:支持联网打印账单(共享打印机控制)
3.更新:新版菜品免费模式,支持西餐厅免费菜品的功能

2005.08.17 - 2005.09.08版本:3.11.123
1.更新:重大更新:重新编写了出品单打印的模块,在XP下面也可以打印出品单了
2.更新:重新设计了打印模块HHPrinter.dll,可以为所有程序共享使用,为新版报表设计器的第一版
3.更新:至此,所有模块完成向XP环境的移植,效果良好

2005.08.03版本:3.10.123
1.更新:选择客户的问题
2.更新报表里面日营业数据汇总比营业报表消费总额多的问题
3.更新:出品程序中免费的菜品继续显示不隐藏
4.更新:报表里面月营业汇总报表增加了日期选择功能
5.更新:拟定于8月中旬更新主版本号,正式发布3.10版

2005.07.22版本:2.10.122
1.更新:完成了IC刷卡积分储值消费
2.更新:完善了VIPMIS的充值管理功能

2005.07.13版本:2.10.121
1.更新:添加了收银买单刷会员卡,使用平价的功能
2.更新:增加了收银买单刷会员卡,操作员可以自由使用平价开关的功能(即是会员也可以不平价)
3.更新:收银添加了按照钟点收包厢费的功能(FOR米兰酒吧)

2005.07.06版本:2.10.120
最近三个月添加如下功能:
1.支持会员卡刷卡买单
2.支持会员卡预付费买单
3.重新制作了结账界面,将买单和改单统一制作,统一规格
4.彻底去掉了F9买单时账单分配的问题,用新思路,打印账单时分配流水号并且保存账单,如果保存过(打印过)的账单删除,需要验证权限
4.会员卡刷卡支持多线程刷卡,完美解决了刷卡操作不方便的问题
5.去除了多余的窗口XP风格模拟的功能(主框架仍然保留原始风格2003版)
6.支持多分店会员联网刷卡积分管理
7.支持多线程联网读取分店会员资料
8.添加了会员管理模块
9.推出了新的客户端配置工具Config.exe,便于咖啡厅软件系统配置与维护
10.推出了新的吧台酒水库存模块
11.推出了新版的高级数据中心模块,将所以数据集中管理,文件名为AdvDmc.exe
12.更新:拟更新一次主版本号

2005.04.25版本:2.9.118
1.修正:出品程序不能保存选项里面的第三个选项的BUG

2005.04.08版本:2.9.118
1.更新:添加了酒水库存联机功能
2.更新:数据导出不影响吧台酒水库存核算功能

2005.04.03版本:2.8.117
1.更新:餐饮打印账单添加了"开台时间","结账时间","结账日期","VIP号码","VIP姓名","打印时间"等几个打印项目
2.更新:收银台结账时可以重新输入人数

2005.03.31版本:2.8.116
1.修正:新版打印账单时不能打印自定义项目的BUG

2005.03.30版本:2.8.116
1.更新:报表程序导出数据时总是采用覆盖的模式(即不会多次把相同的营业数据导出到一个备份文件中)

2005.03.02版本:2.8.116
1.修正:收银程序选定某张账单修改时有时会出现非法操作的BUG

2005.02.02版本:2.8.116
1.更新:制单出品程序做了重大的速度方面的优化
2.修正:制单出品程序修改了完成大量菜品时收到大量进单时出现非法操作的BUG

2005.01.29版本:2.8.115
1.更新:下单台增加了粘贴餐桌菜品的权限判断

2005.01.08版本:2.8.114
1.更新:收银程序彻底抛弃了原先的送菜标志(送菜一律跟免费菜品统一操作,先正常输入,然后免费掉)
2.更新:前台收银程序彻底删除了老方式下的关于退菜数量的操作(要么删除取消一行菜品,要么用负数退单)
3.更新:报表查询重新调整了工具条的按钮,添加了新的报表"免费菜品报表",重新调整了默认的报表打印格式

2004.12.26:版本:2.8.113
1.更新:菜品添加了一个字段(使用优惠券时就不打折),解决了部分营业场所规定使用优惠券时部分菜品不允许打折的问题
2.修正:数据中心更新第一个菜品后不能正确刷新的BUG

2004.12.19:版本:2.8.113
1.更新:出品程序的新的催菜提醒方式.
2.更新:下单程序的数量列加宽
3.更新:下单程序添加开台输入人数功能

2004.12.15:版本:2.8.113
1.更新:重新规划了修改账单和日结功能菜单和界面

2004.12.10:版本:2.8.113
1.更新:收银优化了注册表项目算法,加快了运行速度
2.更新:正式确定,OFFICE数据库文件名为HyHisDB20.mdb(带样本数据),导出数据库模版为Empty.dat(无数据)
3.更新:数据库中T_Check字段添加了两个新字段
4.更新:服务器添加了注册码集中管理的能力

2004.12.09:版本:2.8.113
1.更新:添加了最低消费项目
2.修正:收银台程序没有正确开台时打印随机人数的BUG

2004.12.08:版本:2.8.113
1.修正:下单程序中没有任何餐桌时会出现非法操作的BUG

2004.12.06:版本:2.8.113
1.更新:收银程序中添加菜品时不检查是否选择了财务核算类别的不足

2004.12.2版本:2.8.113
1.修正:收银签单操作中的一些不便之处

2004.11.22版本:2.8.112
1.修正:报表查询导入导出数据库时会错误转换字段类型的BUG
2.更新:收银台结账时签单选择客户按照单位名称分类选择的不方便之处
3.更新:数据中心对客户资料的管理级别
4.修正:数据中心不能修改客户积分资料的BUG
5.更新:收银程序添加VIP客户消费积分的功能
6.更新:报表查询客户资料添加显示消费积分记录
7.更新:注册码的保存方式作了变化,部分老的客户程序可能需要重新注册

2004.11.06版本:2.8.111
1.更新:HySetup.exe添加了对TAB键的支持

2004.11.02版本:2.8.110
1.修正:打开sa带口令的SQLSERVER数据库的BUG

2004.10.24版本:2.8.109
1.更新:报表查询不能设定访问网络共享目录上的HyHisDB20.mdb数据库的BUG

2004.10.16版本:2.8.109
1.修正:收银程序输入新的菜品超过表格能显示的行数后不能正确定位的BUG
2.更新:收银程序添加了开台输入客人人数的功能(并且能打印出来)

2004.10.06版本:2.8.108
1.修正:报表中导入导出数据库,有时不能正确导入日期型数据的BUG
2.更新:收银程序账单打印实现了DLL化
3.更新:制作单程序实现了制作单打印DLL化,但是打印死机问题有待测试,功能有待增强
4.修正:制单出品程序排除了菜品多忙碌时出现非法操作无法打印的BUG

2004.10.03版本:2.8.107
1.修正:报表查询中在空的签单报表上双击表格会出现"实时错误"的BUG
2.更新:前台收银取消了初始化业务数据的功能
3.更新:报表查询中菜品销售报表中的过滤条件内容进行了调整(取消了收银员,增加了餐段等)
4.更新:收银程序打印账单采用了单独的功能模块实现

2004.09.29版本:2.7.106
1.修正:收银程序未联机时的许多可能触发的错误
2.修正:收银打印收银账单不能正确打印单位列的BUG
3.更新:收银打印收银账单增加了"先打印加菜再打印退菜"的溢香厅酒店欣赏的样式

2004.09.14版本:2.7.105
1.更新:收银程序可以读取当前日期和餐段的预定菜品信息
2.更新:报表导出数据可以记录路径,验证.mdb的扩展名

2004.09.10版本:2.7.104
1.更新:数据中心修改了操作员权限的名称
2.更新:收银程序的日结功能进行了优化,增加了"是否允许修改营业日期"的权限
3.更新:预定程序重新设置了餐桌状态图标,并且实现了和其他模块的状态同步

2004.09.05版本:2.7.103
1.更新:账单打印抛弃了PrintType.dat文件方式,采用的菜品的财务核算字段分类
2.更新:增加了分类打印菜品不打印小计的功能
3.修正:数据中心修改菜品的财务核算属性字段时不能马上更新的BUG

2004.09.02版本:2.7.103
1.更新:收银程序可以根据选项来取消已经免费的菜品
2.更新:各个程序对于套餐明细的处理方法

2004.08.26版本:2.7.103
1.修正:制单程序无法正确打印未知新菜品到正确的餐桌的BUG
2.更新:制单程序动态读取新菜品的资料,避免了无法实时显示新菜品的不足

2004.08.17版本:2.7.102
1.更新:收银台程序,如果是单机版在运行的话,第一次联机时会判断服务器是否在运行,如果没有运行会自动启动服务器
2.更新:增加了活动About功能
3.修正:新版本账单设计器的不能正确读出纸张大小的BUG
4.修正:新版报表查询工具查询菜品销售报表时会出错退出的BUG
5.修正:收银程序同步添加菜品不能处理财务核算方式的BUG
6.更新:客户资料编辑的新风格
7.修正:最近版本收银程序不能正确签单的BUG
8.修正:双击营业报表行出错的BUG

2004.08.12版本:2.7.101
1.修正:前些天的版本出现的修改账单中打印出已经取消过的菜品的BUG(未判断是否已取消)

2004.08.05版本:2.7.100
1.更新:制单出品程序增加了打印"换桌单"的功能

2004.08.02版本:2.7.100
1.更新:餐桌买单后马上清空菜品显示
2.更新:用户可以自定义每行排列的餐桌的个数
3.更新:报表查询工具增加了营业分析功能

2004.07.30版本:2.7.100
1.更新:支持附加条件按照编号和助记符查找
2.更新:收银和下单可以合并

2004.07.27版本:2.6.99
1.更新:收银菜品输入窗口的数量框
2.更新:打印收银单时可以紧跟菜品打印费用(菜品,酒水,烟杂,实收)

2004.07.22版本:2.6.98
1.更新:交接班时输入密码的窗口可以连续按"回车"键

2004.07.16版本:2.6.98
1.更新:恢复了"合并"显示菜品的功能

2004.07.14版本:2.6.98
1.更新:制单程序重新打开时不能正确读取已点单未出品菜品的BUG
2.更新:制单程序打印出品单时时间参数不能正确打印的问题.

2004.07.09版本:2.6.97
1.更新:数据中心,菜品资料列表显示是否有附加条件

2004.07.04版本:2.6.96
1.修正:收银程序,在免费菜品时有时会出现非法操作的BUG

2004.06.21版本:2.6.96
1.更新:重新修改了菜品的分单方式,按照厨房来分,不再通过类别来实现,这样可以减少错误和遗漏

2004.06.11版本:2.6.95
1.更新:RSLink.exe实现了自动从Internet上下载更新版本的功能,并且能够对自身进行完美升级
如果按照如下格式设计升级信息文件,可以一次升级多个文件,并且替换自身
**********************************************************************************
*文件名:Update.ini,存放于网站上,自动升级程序将会自行决定是否升级(默认是自动检查)
[HyHis27]
VERSION=2.79394
FILE0=/Update/HyHis30/RSLink.exe
FILE1=/Update/HyHis30/HyHis.exe
FILE2=/Update/HyHis30/HyDataMan.exe
FILE3=/Update/HyHis30/HyQuery.exe
FILE4=/Update/HyHis30/Rpdesign.dll
FILE5=/Update/HyHis30/WhatsNew.txt
**********************************************************************************

2004.05.31版本:2.6.94
1.更新:解决了在NT/2000/XP/2003平台上的打印账单不能正确走纸的BUG
2.更新:彻底解决了账单设置中不打印的项目仍然打印的BUG

2004.05.26版本:2.6.93
1.更新:自动升级程序添加了自动保存开机启动的功能
2.更新:服务器添加了设置自动启动的功能

2004.05.19版本:2.6.93
1.更新:下单程序添加了动态显示当前日期和时间的功能

2004.05.16版本:2.6.92
1.修正:收银程序前面版本修改的实收金额被保存到折扣金额的BUG

2004.05.16版本:2.6.92
1.修正:收银账单上不能打印"自定义帐单号"的BUG
2.修正:换台丢失用户自定义单号的BUG
3.更新:断开连接会自动重新启动计算机

2004.05.15版本:2.6.91
1.修正:找回了"合并打印菜品"项目

2004.05.14版本:2.6.91
1.更新:数据中心使用单独的刷卡文件CardDM.ini

2004.05.13版本:2.6.90
1.修正:修改账单将部分打折和全部打折弄反的BUG

2004.05.11版本:2.6.89
1.修正:下单程序退出登录状态可以直接清空菜品的BUG

2004.05.08版本:2.6.88
1.修正:各个版本修正重大错误,即结账时如果手工事先指定了付款记录,那么会将所有付款金额计算到折扣金额的BUG(该问题首先在名欧发现,但是没有找出原因,但是今天在五马名豪酒店出现后,现场去试验发现了问题所在)1.7版本也已经更正过来

2004.05.05版本:2.6.87
1.更新:报表查询酒水销售可以查看免费的菜品报表
2.更新:终结营业时检查工号和密码

2004.05.02版本:2.6.87
1.更新:报表查询添加了营业报表中察看每条单据的消费明细的功能,方法是双击改单据
2.更新:收银程序添加了打印折扣率
3.更新:收银程序添加了保存当前营业日期和交接班中结束当前营业日期,防止零点后日期自动后延到第二天,导致报表查询不准的错误

2004.05.01版本:2.6.87
1.修正:收银程序不能正确读取F9快捷键选项的错误

2004.04.30版本:2.6.86
1.修正:收银程序不能正确保存折扣方式的问题

2004.04.28版本:2.6.86
1.更新:下单程序不能正确处理套餐明细项目的附加备注的BUG
2.修正:出品程序不能正确处理清空餐桌菜品的BUG
3.更新:出品程序出品历史记录的格式

2004.04.27版本:2.6.85
1.更新:出品程序添加了换台处理功能
2.更新:下单程序添加了菜单中选择显示价格和金额列的功能
3.更新:下单程序调整了列宽度
4.更新:下单程序对点菜数量的控制能力
5.修正:收银台换台不能更换账单号的BUG
6.修正:出品程序出品历史记录时间错误的BUG
7.更新:下单台调整了餐桌图标的间距的列数(+1)

2004.04.26版本:2.6.84
1.更新:所有程序添加了自动升级功能
2.更新:出品和下单添加了聊天功能

2004.04.20版本:2.6.83
1.更新:收银台程序点单时使用操作员的用户名称而不再使用工号
2.更新:下单和出品程序添加了服务器端运行不进行系统操作的功能

2004.04.19版本:2.6.83
1.更新:取消菜品后不再显示(下单)
2.更新:添加了"叫起"状态
3.更新:下单程序添加了点菜后是否继续保存菜品编号供选择的功能

2004.04.16版本:2.6.83
1.更新:制单程序的出品历史记录可以长期保存并且可以清空了(写在文本文件"制单记录.txt"中),清空该记录文件时,是将其按时间改名后存放.
2.更新:下单程序,取消后的菜品不再显示

2004.04.11版本:2.6.82
1.更新:下单程序,菜品列表上右键快捷菜单的快捷键提示错误
2.更新:下单程序添加了保存和读取菜品备注的功能
3.更新:下单,出品都能刷新察看菜品备注信息
4.更新:下单程序可以要求输入台卡号(且无法修改),是否使用此功能在"数据中心"选项里面设置
5.修正:可以正确的选择签单客户
6.更新:结账时可以直接输入客人的VIP卡号码,查询客人打折信息,并计算
7.更新:收银结账时根据权限决定是否可以全部打折

2004.04.06版本:2.6.81
1.更新:添加了合并餐桌菜品的提示和处理

2004.03.27 版本:2.1.80
1.更新:下单\出品添加锁定计算机功能
2.更新:服务器添加了新建连接时,发送锁定计算机命令

2004.03.26
1.表T_Dish添加字段F_FLName nvarchar(50)

2004.03.16 版本:2.0.77
1.更新:修改图标SIZE为40

2004.03.03
1.更新:报表查询之签单报表添加了客户签名列
2.更新:前台收银不能正确打印当前餐段
3.更新:前台收银不能正确保存打折方式的BUG
4.更新:数据中心里面客户资料修改更完善(可以保存单位名称,以及编号防止重复)
5.更新:前台收银客户资料添加跟数据中心统一,完善
6.更新:数据中心对客户资料管理的完善与优化
7.更新:数据中心"选项"窗口添加了"初始化账单流水号"的功能
8.更新:前台收银里面客户签单功能进行了强化,便于手工操作提高速度

2004.02.22 版本:2.0.75
1.更新:制单程序暂停打印快捷键改为Pause
2.更新:制单程序加菜窗体的列索引错误

2004.02.09 版本:2.0.74
1.更新:制单程序,暂停打印的快捷键更换为F11
2.更新:下单程序在状态栏增加了台位使用数字
3.更新:下单程序添加了未买单的台位数据报表窗体
4.更新:数据中心添加了新的权限"查看台位数据报表"
5.更新:制单程序,打印部分做了最新优化,同收银1.6版

2003.12.27 版本:2.0.73
1.更新:在前台收银程序里面,添加了根据Index定位菜品索引时,如果找不到就从数据库读取的功能

2003.12.24版本:2.0.72
1.更新:报表查询里面的酒水菜品报表添加按照制单人工号查询的功能

2003.12.22 版本:2.0.71
1.修正:制单程序重新启动后,会把退菜单显示在界面上的BUG(如果操作员试图将其制单的话,会造成打印浪费)
2.更新:制单程序添加了查看最近制单的历史记录的功能(在HyConfig.dat文件里面修改保存的历史记录的行数)
3.更新:制单程序里面添加了选定菜品的快捷键(回车)
4.更新:制单程序添加了暂停打印菜品的功能
5.更新:结账时,(制单台和出品台可以改变菜品状态为制作状态,但不可以添加新菜品或者取消,下单台完全不允许操作)
6.更新:结账状态时,下单台程序禁止剪切或者复制菜品
7.更新:收银台打印方式重新调整(不合并菜品),避免浪费系统资源,另外发现1.0版本的打印程序有浮点数比较的BUG
8.更新:增加了在下单台催菜,在制单台提示的功能
9.更新:下单程序增加了修改用户密码的功能
10.修正:修正了改版后的不能保存结账单餐段的BUG(未实现的功能包括新版的自动计算包厢费)
11.修正:修正了改版后的修改账单界面不能正确打印付款记录的BUG

2003.12.21 版本:2.0.70
1.更新:制单程序添加打印下单人工号和时间
2.更新:收银程序付款明细添加换行
3.更新:收银台下单直接为完成状态,避免重复出现在制作台上

2003.12.20 版本:2.0.69
1.更新:下单程序点菜时出现折字
2.修正:收银程序里面不打印收款情况的BUG
3.更新:制单程序退菜不显示
4.更新:下单程序不再判断菜品价格

2003.12.19 版本:2.0.68
1.更新:收银台不再合并显示菜品
2.更新:收银台显示菜品时,如果菜品可以打折,则在价格后面显示折字
3.因为程序进度的原因,取消了双击表格退菜的功能

2003.12.16 版本:2.0.67
1.更新:前台收银添加菜品免费功能(解决免费券的优惠加打折的方式)

2003.12.14 版本:2.0.66
1.更新:数据中心程序用户管理界面,用户资料按照工号进行排序后显示,便于查找

2003.12.12 版本:2.0.66
1.修正:前台收银程序不能正确处理付款方式的问题
2.更新:前台收银可以打印付款记录了
3.更新:前台收银程序结账时对付款记录的处理方式
4.更新:前台收银和数据中心启动时,自动检查默认的付款方式是否存在(至少要有一种付款方式)
5.更新:在服务器上可以识别所有客户端的性质

2003.12.01
1.添加菜单ID_MENU_DISH及子菜单
2.Doc类添加方法CancelOneTableDish(CTable *pTable, long lngIndex)
3.修改了CTable类的SumDishCount方法
4.MakeDish程序添加了退菜(取消菜品)的方法

2003.11.30
1.完成了套餐的处理方法
2.修正:制单程序,当你选择了第一个菜品制单后却删除了2个菜品的BUG

2003.11.29
1.套餐资料修改
2.套餐的处理方法

2003.11.10
1.基本完成70%的程序框架

(2003.11.1)版本:1.5.67
1.修正:上个版本修改所导致的F9直接打印权限判断的BUG

(2003.10.29)版本:1.5.66
1.更新:重新设计了功能更加强大的注册方式

(2003.10.25)版本:1.4.65
1.更新:预定管理里面,将人数排在了桌号前面,当按下ESC键时,将焦点设置到人数上
2.更新:在预定窗体上,连续两次按下ESC键,就清空窗体上的信息
3.修正:预定报表里面关于"等待""过期"的判断错误的BUG
4.修正:前台收银程序里面,在修改账单时,当更换了挂帐客户时,原始客户的欠账金额不会减少的BUG

(2003.10.15)版本:1.4.64
1.更新:前台收银和数据中心里面清空业务数据针对SQL SERVER采用了新的算法,不在日志文件里面留下痕迹,防止反删除,让数据更安全
2.更新:数据中心里面清空系统数据重新改写,提示内容和图标也重新改写
3.更新:预定管理将人数放在第一顺序,姓名第二,电话第三
4.更新:预定管理将餐桌当前使用状态和预定状态合并,可以同时显示
5.更新:预定管理的预定报表可以删除了,并且不再显示已经取消的预定
6.修正:修改密码窗口的一个错误

(2003.10.06)版本:1.4.63
1.修正:当焦点落在点菜框上时会绕过权限检查的BUG
2.更新:将数据中心里面的清除系统数据功能移动到了"查看"菜单下面,避免跟"清空业务数据"功能混淆

(2003.10.06)版本:1.4.62
1.更新:预定管理里面修改预定抵达状态为加上标志
2.更新:预定管理添加灵活的预定报表查询
3.更新:数据库中预定表添加了一个字段
4.修正:前台收银中,当一张餐桌被占位之后应该禁止被输入菜品,给出提示
5.修正:退菜时的浮点数比较问题

(2003.09.29)版本:1.4.61
1.更新:数据中心里面添加"客户单位"和"客户资料"管理功能
2.更新:数据中心里面,数据显示界面更漂亮
3.更新:数据中心主窗体的标题

(2003.09.25)版本:1.4.60
1.更新:交接班时,Admin(系统管理员)账号可以察看所有人的账单,也可以察看某个人的账单
2.更新:数据库设置程序可以任意指定Access数据库文件名,但该文件必须是标准数据库文件的拷贝版本(具有相同的数据库结构),而且必须存放于系统安装目录下面
3.修正:打印账单时,项目在账单设计器里面指定"不打印",在收银里面仍然打印的错误
4.修正:账单打印时,人数错误
5.修正:报表查询,时价条件设置中有个语法错误,以及不能排序的BUG
6.修正:报表查询中使用新版本报表打印组件后带来的若干小问题
7.更新:前台收银对没有修改菜品权限的操作员将价格栏禁止
8.修正:数据中心里面菜品打印时,只打印双数的BUG

(2003.09.22)版本:1.4.59
1.修正:数据中心里面新建餐段时,时间变量没有初始化导致非法操作
2.更新:数据中心里面保存菜品按照菜品编号唯一处理,不再允许重复编号存在
3.更新:数据中心里面添加了新菜品之后,双击修改刚添加的新菜品时,可以正确的索引了
4.修正:报表查询里面多个报表的打印预览和直接打印功能颠倒的BUG(由于上个版本开始使用新报表设计器造成)
5.修正:预定管理程序里面,F5按照名称查找预定记录时,出现非法操作的BUG
6.(补)更新:报表查询开始使用新版本的"好易报表设计组件",排除了打印报表的若干错误,并且可以和库存以及其它一些软件报表功能兼容
7.修正:调帐功能不再跟通用功能一起提供

(2003.09.11)版本:1.4.58
1.更新:增加了新的账单编号处理方式,可以支持F9功能选择了
2.更新:相应的在数据中心里面添加了高级选项设置

(2003.08.26)版本:1.2.57
1.更新:预定管理程序中复制预定记录后,查找预定记录显示日期不正确的BUG
2.修正:前台收银程序中,当选择重置所有餐桌之后会导致服务器非法操作退出的BUG

(2003.08.21)版本:1.2.56
1.更新:当一张餐桌翻台之后,将是否使用包厢费标志复位

(2003.08.18)版本:1.2.55
1.修正:打印账单时有时会有部分菜品打印不出来,但是金额又对的BUG,主要是一个类的属性初始化为了1(就是F_Flag)
2.更新:无论是否包含包厢费,都打印包厢费金额,但是实收金额会有所不同,即明示客人又多少包厢费
3.修正:增加了账单号实时功能之后导致一个重复关键字错误的BUG
4.更新:预定管理操作更加方便了

(2003.08.14)版本:1.2.54
1.修正:前台收银部分的一个检查用户权限不准确的BUG,索引错了
2.更新:F9之间打印账单添加权限控制,清空餐桌添加权限控制

(2003.08.10)版本:1.2.53
1.修正:结账和改单界面上处理包厢费的一些错误
2.更新:添加可选项目,在免掉包厢费时是否打印"免"字

(2003.08.08)版本:1.2.52
1.更新:添加选项窗口,由收银员自己决定在菜品列表窗口上显示哪些项目
2.更新:添加新权限"是否允许在前台修改菜品"
3.更新:添加多处未联机提示信息
4.修正:数据中心处理用户权限时的一个BUG(漏掉了三个新增的权限)

5.更新:流水账单号改为动态,保证在F9打印里面也打印出跟该结账单一致的账单号,剪切复制也已经修改过来了
6.更新:在PrintType.dat文件中指定打印划分的类别,进行灵活的分类打印

(2003.08.06)版本:1.2.51
1.更新:数据中心修改餐桌资料不再改变餐桌当前状态
2.更新:相关部件可以动态修改数据库名称(在HySetup里面设置,以前是默认值为HyHisDB)
3.更新:当服务器关闭后,工作站退出会有非法操作的BUG
4.更新:打印账单时按照菜品类别将菜品排序后再打印出来
5.更新:预定程序添加双击直接登记的功能
6.更新:预定程序查询预定时不显示预定(到达日期)的BUG

(2003.08.3)版本:1.2.50
1.修正:无论是否包含包厢费,在应收金额里面都不包含包厢费(只包括消费金额)

(2003.08.01)版本:1.2.49
1.修正:工作站端当重新连接服务器后,会丢失Socket套接字对象(内存)的BUG
2.更新:餐桌菜品列表上,当更换餐桌时,不会重新调整表格的格式了
3.更新:可以合并或者分开显示菜品列表
4.更新:只有在包含包厢费时,才打印包厢费
5.更新:打印账单应收金额不包含包厢费
6.更新:表T_Table添加F_TableNo字段char20
7.更新:表T_Check添加F_WtNo字段用于保存点菜员编号
8.更新:餐桌分别有了编号的名称属性,可以在打印账单时,设置为打印编号或者名称

(2003.07.30)版本:1.2.48
1.更新:账单格式设置添加自定义项目功能
2.更新:前台收银打印账单可以打印自定义项目了
3.更新:前台收银打印账单时每张单都打印页眉项目
4.更新:点单时,可以自由设定是否完全匹配编号或者名称等,以减少回车次数

(2003.07.29)版本:1.2.47
1.更新:账单打印出现乱码的问题
2.更新:包厢费设置功能的错误
3.更新:修改餐段的BUG(更新为1.2版带来的)
4.更新:不能正确修改用户口令的缺陷
5.更新:点菜列表里面进行了长度格式化

(2003.07.27)版本:1.2.46
1.更新:数据中心界面做了重新改写,更方便操作,可靠
2.更新:前台收银账单打印字体处理的小问题
3.更新:开始支持包厢费(按照餐段)的功能

(2003.07.25)版本:1.1.45
1.更新:预定管理修改了查找预定功能
2.更新:前台收银打印字体可以正确的使用字号大小了
3.更正:前台收银程序打印时会打印错误流水号的错误
4.更正:数据中心程序,系统启动时检查默认用户的功能有个小错误

(2003.07.23)版本:1.1.44
1.更新:报表查询中显示签单报表有个小错误

(2003.07.22)版本:1.1.43
1.更新:预定管理中改正了修改预定时无法更换餐桌的错误
2.更新:预定管理中添加了预定表打印的功能
3.更新:预定管理中添加了按照电话或者姓名,和日期数据查询预定记录的功能

(2003.07.17)版本:1.1.42
1.更新:报表查询里面添加了一个营业额分析图表,算是辅助决策工具的起点
2.更新:排除了排行榜里面的一个实时错误

(2003.07.07)版本:1.1.41
1.更新:纠正了不能正确处理自定义纸张大小的错误
2.更新:数据中心里面的菜品显示时,按照类别->编号的顺序排列

(2003.07.03)版本:1.1.40
1.更新:表T_Check添加字段F_DishFee,F_DrinkFee,F_SmokeFee字段直接保存三种消费汇总,查询时,无须再重新统计,加快显示速度
2.更新:交接班记录时,调整了显示布局,增加了光标提示
3.更新:买单和改单时,开始直接保存三种消费金额了
4.更新:报表查询添加自动更新数据库中数据的功能

(2003.07.01)版本:1.1.39
1.更新:所有表添加F_CF字段
2.更新:新增TD_SQL表
3.更新:新增TD_Trans表
4.更新:新增TD_Option表
5.从这个版本开始,本系统开始支持"数据库镜像"功能
6.前台收银系统的"初始化业务数据",不再将计数器置0
7.注册软件无须重新打开系统了
8.更新:表T_Users添加F_ID字段

(2003.06.27)版本:1.0.38
1.更新:T_OrderBill表添加F_ClientID字段(smallint)默认值是-1
2.更新:T_Clients表添加F_Picture字段(varchar100),存放照片路径
3.更新:T_Table表添加F_Reserve字段,确认是否是老板保留不预定的餐桌
4.更新:预定登记时,自动根据电话号码查找客户资料
5.更新:预定登记时,自动根据日期和餐段分配一张未预定的餐桌给客户
6.更新:预定登记时,保存记录时自动保存客户资料
7.更新:T_OrderBill表添加字段F_Canceled表示是否已经撤销

(2003.06.24)版本:1.0.37
1.更新:HySetup开始支持Access2000或者以上数据源设定,版本升为1.0.2
2.更新:前台收银程序开始支持Access2000数据源
3.更新:数据中心程序开始支持Access2000数据源
4.更新:预定管理程序开始支持Access2000数据源
5.更新:前台收银程序,查找餐桌菜品时开始显示数量
6.更新:前台收银程序所有的按钮菜单都增加了动态提示信息
7.修正:前台收银程序,当你没有选中任何餐桌时,就点击粘贴,会出错

(2003.06.23)版本:1.0.36
1.更新:预定的部分功能(添加,删除,查询预定记录)
2.更新:其它小问题若干
3.修正:重组程序后的收银单无法打印(原因是没有初始化指定配置文件为Check.dat)
4.待修正:当数据库中的数据比较多时,使用初始化工作数据会产生连接超时的错误,得考虑用别的方法来实现
5.待修正:数据的导入与导出
6.修正:报表查询里面因为重组之后产生的一些配置文件不一致的错误
7.修正:数据中心里面不能正确保存用户名称的BUG

(2003.06.22)版本:1.0.35
1.更新:添加在所有餐桌按照编号查找某道菜品的功能

(2003.06.21)版本:1.0.34
1.更新:添加表T_DishSet准备用来保存和菜信息
2.修改:T_Users添加F_Name字段
3.在电脑的一次莫名其妙的死机之后,发现我现在在窗体上编辑Static控制时,可以自动改变大小了,奇怪
4.数据中心里面新添加菜品时可以直接指定图片了
5.前台收银开始显示用户的姓名和工号了
6.更新:数据中心里面可以对和菜进行管理了
7.更新:T_OrderBill表添加F_DishSetID字段保存该预定单所指定的唯一的和菜类型

(2003.06.20)版本:1.0.33
1.更新:数据中心里面餐桌也支持图片了
2.更新:能够正确的处理婚宴类型数据了
3.更正:当在某个项目列表中,新插入多条新记录,那么将无法正确的修改第一条新记录之后的新记录
4.更新:T_Item基类添加索引属性
5.考虑:可以考虑扩展支持Access2000数据库

(2003.06.19)版本:1.0.32
1.更新:可以复制餐桌信息了,而且当是剪切餐桌时,执行速度又快了一倍以上
2.更新:客户端登录服务器时,调整了TAB顺序,使操作更方便
3.更新:T_OrderDish表添加字段F_Remark宽度为200

(2003.06.18)版本:1.0.31
1.更新:重新编写预定管理系统(按照新思路)
2.更新:数据中心里面添加指定菜品图片的功能
3.更新:数据中心里面,删除数据时,检查是否可以删除的功能
4.修正:数据中心里面当单击某菜品时,无法正确显示菜品所属类别的BUG
5.更新:可以指定某菜品为"和菜"(即套餐)的属性
6.更新:T_OrderBill表添加F_Feast字段指明宴席类型
7.更新:T_Table表添加F_Picture字段保存图片文件
8.更新:T_CheckList表添加字段F_Statu(整型)
9.更新:T_TableList表添加字段F_Statu(整型,供自动出品用)
10.修正:HySetup.exe不能够正确保存数据库类型的问题

(2003.06.17)版本:1.0.30
1.找到了死机的病因(类似XP界面的实现代码有GDI对象丢失的BUG,拟考虑抛弃仿XP风格界面)
2.客户资料按照"单位"->"个人"的模式划分层次

(2003.06.15)版本:1.0.29
1.修正:报表查询里面有个按钮没有改变状态
2.更新:报表查询开始支持Access数据库
3.更新:数据中心开始支持Access数据库
4.更新:前台收银程序,数据中心,报表查询统一使用相同的配置文件HyConfig.dat,并且有统一的设置
5.更新:系统设置程序HySetup.exe完成
6.更新:账单设计器也采用Check.dat保存设置
7.修正:前台收银当选择清空工作数据后,点击取消也会提示已经清空的消息

(2003.06.14)版本:1.0.28
1.更新:前台收银部分开始支持Access数据库(通过设置程序)
2.更正:前台收银在窗口大小改变时,重新排列餐桌避免了出现空白行
3.更新:前台收银程序餐桌的排列方式可以选择固定列数(12),也可以选择动态排列
4.更新:重新分配了配置文件的功能和名称
5.添加:设置程序框架

(2003.06.13)版本:1.0.27
1.更新:更换餐桌时大大加快了速度,菜品越多越明显

(2003.06.10)版本:1.0.26
1.更新:报表查询里面,菜品销售查询添加按照收银员编号

(2003.06.06)版本:1.0.25
1.修正:前台收银系统,修改账单中输入拼音或者不完整的编号,出现多个菜品时,不显示价格信息
2.更新:退掉中间某个菜品后ID编号不按照顺序递增的缺憾

(2003.06.05)版本:1.0.24
1.修正:修改账单保存单据打印时,会打印出双倍的菜品酒水烟杂费用,因为在刷新过程里面该变量没有清0
2.更新:打印账单时,将打印文档名称设定为当前打印的餐桌的名称
3.更新:点菜界面上按下F11-F12键删除菜品之后,焦点消失的问题
4.客户端打印死机问题(怀疑有死循环)

(2003.06.03)版本:1.0.23
1.修正:各地方菜品排列顺序
2.修正:客户付款记录按钮的标题
3.修正:客户签单记录的消费汇总跟营业报表,前台一致.
4.更新:前台收银在收银员交接班时,增加了删除账单功能.

(2003.06.02)版本:1.0.22
1.更新:报表查询添加"时价报表",实际上就是可以按照类别查询菜品资料并打印

(2003.06.01)版本:1.0.21
1.修正:正确打印结账时间,精确到″
2.修正:当菜品行数超过一页时,无法打印第二页菜品的BUG
3.更新:数据中心里面可以任意的打印预览任意页面的菜品资料,并且速度飞快

(2003.05.31)版本:1.0.20
1.修正:打印账单时时间格式化在秒位上会产生很长的一串数字
2.修正:打印账单,行间距无效的错误

(2003.05.30)版本:1.0.19
1.更新:数据报表里面添加收款报表,可以分门别类的查询收款数据
2.更新:数据报表里面查询营业报表时,可以指定餐段了
3.更新:前台收银程序,登录时添加日期选择,可以指定登录日期
4.更新:前台收银程序收银员交接班时,添加了折扣合计项目,并增加了账单显示日期和餐段信息

(2003.05.28)版本:1.0.18
1.修正:数据中心里面数据不能删除
2.更新:数据中心里面,数据报表打印功能(未完,待续)
3.修正:报表查询里面,计算机名,用户,密码,数据库名称都自动寻找默认值,如果没有设置的话

(2003.05.24)版本:1.0.17
1.修正:数据查询里面统计菜品酒水烟杂消费汇总有误
2.修正:前台收银里面添加新客户当前欠款额置为0
3.更新:数据报表里面酒水查询添加金额和数量以及汇总
4.更新:数据报表里面酒水报表空数量行不显示

(2003.05.22)版本:1.0.16
1.修正:修改账单里面,当当前的付款方式超过一种时,保存账单时会保存多条付款记录的错误.
2.修正:营业报表打印报表条件
3.修正:酒水报表打印报表条件
4.修正:添加新菜品时没有保存备注
5.修改:新菜品保存成功后不再询问用户是否继续添加,而直接清空窗体
6.修改:在选择新的菜品类别后将名称等项目清空

(2003.05.21)版本:1.0.15
1.修正:前台收银部分有个错误,"新添加的菜品在重新启动程序之前,会无法识别消费类别,所以修改账单,新账单时会发生计算错误.

(2003.05.20)版本:1.0.14
1.更新:数据中心里面的总体界面进行了修改(尚未做完)

(2003.05.07)版本:1.0.13
1.修正:添加新菜品窗口上,当光标被置于菜品编号时,全选中菜品编号
2.修正:营业报表中没有象前台收银一样的进行实收款去零头
3.增加:一次性将所有餐桌的打扫状态置为空闲状态
4.修正:修改账单于结账中对折扣金额和实收金额的计算方法
5.增加:查询报表里面添加汇总功能
6.修正:数据中心里面的餐段资料编辑功能错误

(2003.05.04)版本:1.0.12
1.报表查询里面完成了客户签单账目报表的查询以及打印
2.报表查询里面的客户签单账目菜品明细的查询和打印
3.前台收银里面由于上个版本修改导致的一个逻辑错误(无法保存正常买单的单据)

(2003.04.29)版本:1.0.11
1.修正了修改账单里面的一个计算错误(保存折扣金额错误,会导致前台与报表查询数据不一致)
2.扩充了一个功能,保存挂帐客户的当前挂帐金额,便于管理
3.报表查询里面添加了挂帐报表,客户付款资料管理,增加了"修改客户付款记录"的权限

(2003.04.24)版本:1.0.10
1.加号(+)定位餐桌的实时性
2.上一个修改版本导致的修改账单是F12无法退菜的BUG
3.重新设计了显示桌面的程序
4.修正了当一个餐桌为空时打入退菜会改变餐桌状态为使用的BUG
5.报表查询里面"菜品消费报表"添加了按照类别进行查询的功能
6.前台收银程序里面,优化了"剪切"->"粘贴"餐桌菜品功能的算法,让运行速度更快,同步更迅速
7.修改了在修改账单里面不能按照拼音首字符输入菜品的BUG

(2003.04.23)版本:1.0.9
1.退菜时的份数检查
2.重新写了餐桌状态的显示图标部分,解决了有时会出现餐桌名称字符消失的BUG
3.修正了空的餐桌可以用退菜来改变状态为使用状态的BUG
4.修正了修改账单界面上F12快捷键不能用的BUG
5.重新编写了修改账单界面上添加,填充菜品,删除菜品的代码,使之与主界面上的一致

(2003.04.22)版本:1.0.8
1.修正了修改结账单时,退菜金额只增加不减少的BUG
2.交接班时,双击账单条可以直接打开修改界面
3.修改菜单中删除份数不能任意设置
4.点单时的当前输入的菜品跟踪
5.包含日期时间段的汇总审核功能
6.修正了修改账单里面的一个不能够正确显示消费记录的错误

版本:1.0.7
问题若干

版本:1.0.2
1.解决了F2和F4快捷键的问题
2.餐桌名称字体更纤细了

2003-04-13 15:22
今天终于发布1.0版!

2003-04-13 以前
...............!!!!!!!!!!!!!!!!!***************%%%%%%%%%%%%%%^^^^^^^^^^^^^
$$$$$$$$$$$$$$$#################(((((((((((((((@@@@@@@@@@@@@@~~~~~~~~~~~~~
...;;;;;''''梦想:":""<>?"?">"::???????????????????????????????????????????


开始

好易软件

浙江省温州市灰桥机电电脑市场405#

电话: 0577-88835007

Email:163_zhp@163.com

版权所有：好易软件工作室

网址: http://www.wzhaoyi.com


下载：

用户可以从我们的网站上下载演示版软件安装,URL是

1.http://www.goodeasy.net.cn

2.http://wzgsl.3322.org/down

3.http://goodeasy.meibu.com/down

您可以打开下载页面后点击相应的版本的下载链接，您可以直接点击鼠标右键选择〔另存为〕，也可以用下载工具如迅雷、网际快车等等下载本软件。

本软件的下载链接为可执行文件的安装包，下载后直接执行，按照提示逐步选择安装即可。


主题:如何规划好易餐饮管理系统的安装任务?

针对不同的应用场合,可以选择不同的软件版本安装和进行网络规划.

1.单机版安装:酒店规模不大,餐桌数量不超过60桌,则基本上只需要一台电脑需要运行该软件,请点击这里察看说明

2.网络版安装:酒店规模比较大,餐桌数量比较多,前台需要运行多套收银程序,办公室可以查询报表,请点击这里察看说明

3.咖啡休闲餐饮场所,既需要收银,也需要走廊下单和厨房打单等系列应用,请点击这里察看说明

4.我不清楚该如何规划,请致电好易软件 0577-88330371 咨询!

5.好易餐饮系统工作流程图:


主题:好易餐饮管理系统单机版安装指南

单机版的安装比较简单,请遵从如下步骤完成安装:

1.从网络上下载"好易餐饮管理系统"安装包

2.在需要安装的电脑上完成系统整理和优化,保证计算机名和IP]地址不和网络中其它电脑冲突,而且尽量保证以后计算机名和IP地址也不再变化,如确实有变化的需要,请您与好易软件联系.

3.在安装的计算机上,请安装好Microsoft Office办公自动化软件,这是好易餐饮管理系统V3.0或者以前版本运行所必须的软件环境.

4.确保在目标计算机上安装了TCP/IP协议,大多数具备网卡的计算机上默认应该会安装TCP/IP协议.对于未安装任何网卡的计算机,需要安装"微软拨号网络适配器"自动安装TCP/IP网络协议,详细内容请参阅"TCP/IP相关依赖"主题

5.运行好易餐饮管理系统的安装程序,所有步骤都可以按照默认值进行.建议采用默认安装路径(D:\HH),如果您的硬盘没有D:盘,必须将软件安装在其它盘,根据版本不同可能需要在安装完成后更改相关设置,详细内容请参阅"进行相关的设置"主题.

6.安装完成,请执行数据库的初始化操作,请参阅"如何开始使用好易餐饮管理系统"主题


无标题文档

主题:网络版安装指南

第一部分.规划用户局域网

1.1 网络版需要至少两台计算机,其中一台计算机作为服务器(主机),为另外的计算机提供数据库和餐饮软件服务功能.

1.2 建议采用 服务器/工作站 模式,如服务器端安装 Windows2000 Server版 工作站安装专业版的Windows

1.3 也可以采用对等网,服务器和工作站都可以安装专业版的Windows系统

1.4 网络采用TCP/IP协议,确保各台电脑能互联互通.

第二部分 服务器端[或者单机版]软件安装

2.1 从好易软件网站下载[好易餐饮管理系统]安装包 http://www.goodeasy.net.cn

2.2 参照"安装指南"的内容在服务器上运行"好易餐饮管理系统安装包"安装程序

2.3 安装前先暂停或者关闭Windows防火墙,安装过程中如果弹出加载启动项提示的话,需要点击接受.

2.4 运行好易餐饮管理系统安装程序.

2.5 在安装程序需要选择组件时,如图选择[服务器/单机版]模式,其它选项无需变更.

2.6 在安装程序的最后一步选中选项[启动 自动配置服务器]项目,由安装程序自动完成创建数据库.如果是升级覆盖安装,则无需选中此项目.

第三部分 网络版客户端安装

3.1 先完成服务器安装,确保客户端跟服务器在网络上互联互通.

3.2 运行好易餐饮管理系统安装包,在模块选择部分选择相应的组件[此时无需选择服务器组件],如下图所示:

3.3 在安装的最后一步,选择选项[启动 网络配置工具],如图:

3.4 点击完成后,即会自动弹出好易网络自动配置工具,如下图:

3.5 选择好配置项目,填写服务器IP地址后,点击[开始]按钮,如果顺利即可自动完成工作站配置,如果失败,它会提示失败的项目,针对失败的项目解决问题即可.


如何注册本软件产品

第一步 打开前台收银管理系统

第二步 点击“帮助”->“注册本软件”菜单，如下图：

第三步 在弹出的对话框中，将您的用户识别码反馈给好易软件，将您获得的注册码输入到注册码文本框，点击按钮“给我注册吧”完成注册！

第四步 完成注册！

说明：只有完成注册才能称为好易软件的正式用户，正式用户将获得所有的软件功能，以及免费的软件更新，在线的技术支持，新产品信息等等综合服务产品。


前台收银操作指南

目录：

1. 启动前台收银模块

2. 联机登录系统

3. 修改登录密码

4. 开台、关台、保留台位等

5. 输单

6. 加菜

7. 退菜

8. 修改已点菜品价格或者数量

9. 打印预接账单

10. 指定付款方式

11. 刷会员卡

12. 结帐保存

13. 修改已经结帐的账单

14. 重新打印已经结帐的账单

15. 删除已经结帐的账单

16. 打印前台收银报表

1. 启动前台收银模块：
如果软件正确的被安装，那么在桌面上将会有图标 [image] ，双击该图标即可打开前台收银模块。
注意：如果该图标已经被删除，那么请重新运行安装程序，或者从开始菜单，程序组里面选择快捷方式打开进入。

2. 联机登录系统：
打开前台收银模块后，首先弹出的对话框为“用户登录”，如下图所示：

请在“连接服务器”项目里面输入127.0.0.1(指的是单机版的)，输入工号和密码，初始化密码为空。

3. 修改登录密码：

联机登录进去后程序的左上方有个文件那有个修改密码，如下图：

4. 开台 关台 以及保留台位:

联机登录进去后选择需要开台的台号，双击它会显示：
→输入人数→确定即可。

关台的功能需要权限支持。

5. 输单：

在开台后就可以进行输单了→右边有个编号和助记符 在里面输入菜品的编码（输入菜品的拼音字母的第一个名称）以及编号即可：

比如：输王老吉，输WLJ的三个字母即可，按确定键会有个蓝色的背景出现在数量那，输入你所需要的数量。

6. 加菜：

和输单的形式一样,首先选中需要加菜的台号,在输单那栏（助记符）中输入编号和编码：

输入菜品的第一个拼音字母按确定。如：娃娃菜 输：“WWC“即可。

7.退菜：

方法也是和加菜一样，不同的是在数量那需要输“-” 字 就是加减的意思，“-”代表减。如图：

8. 修改已点菜品价格或者数量：

选中需要修改的菜品名称→按快捷键F10: 如图:

9. 打印预结帐单：

选中你需要打印的台号→双击→会有一个对话框弹出：

点打印或者直接按快捷键F9

10. 指定付款方式:

在结帐的对话框上有个”付款(F2)”，点击付款会有多中选择：”现金，现金券，银行卡等”。如图：

选中你需要付款的方式点确定即可。

11. 刷会员卡：

结帐的界面上有个刷会员卡→点击它 如图：

12. 结帐保存：

在结帐的界面上有个“保存（保存）”点击保存会提示：“你确实要保存结帐单吗？”的字样，点确定，如图：

在保存结帐后，会有个提示“你是否要打印结帐单吗？”：

13. 修改已经保存过的账单：

在刚刚保存过的台号上点鼠标的右键会有一个“显示帐单”，点击“显示账单”里面里刚刚保存过的单子，然后选择其中的单子，双击和者点旁边的“修改账单”如图：

14. 重新打印已经保存过的结帐单：

和修改保存已经过的账单一样 ，旁边有个“打印帐单”，点击打印账单即可：

15. 删除已经结帐的账单:

方法也是和上述一样，在显示账单的右边有个删除账单，点击”删除账单“,如图：

17. 打印前台收银报表：

在桌面上有个图标“ [image] ” 双击该图标即可打开报表查询模块。
注意：如果该图标已经被删除，那么请重新运行安装程序，或者从开始菜单，程序组里面选择快捷方式打开进入。登录进去以后选择“营业“，就会显示当天的营业报表→点打印→

流程：


主题: 数据中心简介

1.数据中心是整个好易酒店管理系统的数据维护模块,它可以完成所有基础数据的管理工作.

2.数据中心程序文件名为AdvDmc.exe,默认被安装在D:\HH目录.

3.打开数据中心需要具有相应权限的用户才能登陆.

4.在数据中心可以完成如下功能:

4.1 用户权限管理

4.2 业务数据初始化

4.3 系统数据初始化

4.4 菜品资料库维护

4.5 餐桌资料库维护(包括包厢费和最低消费)

4.6 签单客户管理

4.7 高级选项设置


主题：清除系统自带的演示数据资料（初始化数据库）

1、请用系统管理员账号登录“数据中心”。

2、在“数据中心”的主界面上选择菜单“数据库”->“清空系统数据库”。（警告：该功能将删除数据库中所有营业数据和基础资料，请小心使用。）


HowAddNewDish

主题:如何添加新菜品资料?

1.打开数据中心(需要权限确认)

2.选择菜单"数据"->"菜品",系统将显示所有菜品资料

3.点击"新建"按钮,弹出如下菜品资料编辑窗口

4.您在该窗口上可以完成新建菜品和修改菜品,新建菜品的方法是直接选择类别,按下回车键,系统会自动分配一个新号码,编辑菜品的方法是把焦点移动到菜品编号框上,输入需要修改的菜品编号,按下回车键,将会调出该菜品的资料进行修改,新建或者修改完毕后点击保存,自动进入新菜品输入

5.您也可以用具有"修改菜品资料"权限的用户登陆到收银系统,直接按下F3快捷键,进入同样的菜品编辑界面

备注:

您还可以在该窗口上通过"增加条件"按钮为该菜品添加附加条件,关于附加条件的信息,请参阅" 菜品的附加条件 "主题.您还可以通过"增加明细"按钮将该菜品设置为套餐,并添加其套餐明细,关于套餐信息,请参阅" 和菜/套餐/组合菜信息 "主题


主题: 建立酒店的客户资料档案库

1.登录"前台收银"

2.点击菜单"工具"->"会员管理"

3.点击"新建"添加新客户,或者选定客户纪录后点击"修改"和删除

4.注意:客户资料的"编号"具备唯一性,有签单纪录的客户资料,在业务数据清空前禁止删除.

5.如图


主题: 建立酒店的餐桌资料库

1.针对酒店的实际情况,将营业餐桌(或者包厢等其它形式的服务单位)进行编号,命名.

2. 登录"高级数据中心"

3.将规划好的餐桌资料录入数据库


主题: 设计酒店个性特色的收银账单格式

每个酒店都有自己印刷的账单样式, 针对不同的账单样式,好易餐饮管理系统提供了高度灵活的样式设计工具,在安装目录(D:\HH)里面的BillStp.exe就是完成账单设计的工具

1.打开BillStp.exe程序

2.测量账单纸张的大小(包括宽度和高度),以毫米为单位输入账单设计器(BillStp.exe)

3.将每个打印项目拖动到指定位置放置

4.设置字体大小

5.设计每页打印的行数

6.模拟打印效果,如果效果不满意再重复上面3 - 5步骤,直到完美为止

7.注意:您也可以不作修改直接使用好易软件提供的默认样式(操作方法是在账单设计器中取默认值)

图例:


主题: 设计符合酒店要求的报表打印格式

说明: 好易餐饮管理系统在提供的丰富报表的同时,也提供了报表的自定义打印工具.

1.登录报表查询工具

2.查询指定的数据报表

3.点击"文件"->"打印预览",即会打开报表设计器

4.实际使用操作效果类似"餐饮账单格式设计器"

5.注意:格式设计完毕,一定要点击"保存"按钮保存格式


1. 联机工作用鼠标单击工具栏上的“联机”按钮，会弹出一个输入工号、口令的登录窗口，请您分别输入正确的工号、口令后点击“确定”按钮，经检查正确而且具有打开“收银管理程序”的权限的话，即可以进入工作台，会在窗口的左边显示餐桌（台位）状态，右边显示菜品输入框，准备输入菜品。

2.选择餐桌

1. 输入菜品

2. 取消菜品输入

3. 退菜输入

4. 增加菜品数量（如增加酒水）

5. 买单结账

6. 打印账单

7. 买单打折

8. 买单加收包厢费

9. 客人签单结账

10. 重新修改已经入账的账单

11. 重新打印已经入账的账单

12. 按照编号定位菜品所在餐桌

13. 高级选项设定


Q:如何在结帐单上指定的位置打印多种消费项目的合计金额？(突破数据中心里面核算类别的限制)

A:我们知道可以在数据中心中指定多个核算类别,比如”冷盘””热菜””海鲜””点心””酒水””烟杂”等等.在该例子中”冷盘””热菜””海鲜”和”点心”都应该统一归纳为”菜品”.但是财务报表里面又需要细分为上述类别,帐单上面又无法打印这么多小计(假设不允许将小计打印在紧跟菜品后面).解决这个矛盾的方法是使用本软件的高级设置项目,”帐单打印公式”,你可以打开帐单设计器(一般为D:\HH\BillStp.exe),添加一个自定义项目,将该自定义项目的标题设置为”$=冷盘+热菜+海鲜+点心”(注意:不要输入引号,冷盘等等项目字面要完全跟数据中心里的核算类别匹配),然后拖动到指定的位置(如帐单上印刷的菜肴的位置),然后保存下来,再打印,你看看效果吧,是不是很理想啊? 灵活运用本软件的功能,没有做不到的,只有想不到的.


主题:为什么需要厨房吧台自动打单程序?

现在越来越多的酒店餐饮企业开始重视计算机在日常营业中的自动化优势，用好易餐饮系统可以实现电脑输单、厨房吧台各个部门自动打印小票制作单，收银台自动记帐的功能，可以大大的方便酒店管理，特别是在场地比较大，多楼层的情况下，点单信息可以迅速的通过计算机系统传递到各个部门。用好易餐饮软件可以实现PDA点单，或者服务员在就近的电脑上输入单子，电脑可以快速分单打印，从而实现酒店点菜信息化。


主题:如何使用厨房吧台打单程序?

1.正确安装与配置好易餐饮管理系统，使其能正确运行。

2.让好易餐饮管理系统支持下单分单模式：需要用ADMIN登陆好易数据中心，设置菜单里面的选项，点击“高级”，选中选项“收银程序支持下单模式” 如下图

2.在服务器上正确安装并且设置小票打印机的驱动程序。并且保证将各个部门的打印机命名为出品部门名称，如厨房的打印机就命名为“厨房”，如下图：

3.在数据中心里面的“出品部门”项目中设置正确的出品部门名称，并且与打印机名称一致。如下图：

4.在服务器上设置开机自动启动制单出品程序MakeDish.exe,并且设置自动登陆系统,方法是将"D:\hh\MakeDish.exe -User=888"命令放入启动项目，让出品程序开机自动用共号888登陆出品制单程序。

5.用ADMIN进入出品制单程序设置出品部门，方法是点击选项。分别设置为如下图:

6.如此配置好出品制单程序后,让其自动运行后,可以隐藏到"通知区域",方法是单击如下图打圈的图标，再次单击则显示窗口,还可以在其选项里面设置为启动后自动隐藏。

7.打开前台收银，联机登陆后，开始输入菜品，一桌菜品输入完毕后，点击工具条上面的“提交”或者按下小键盘上的“/”键，会弹出提示如下图：

点击[是 ]后，菜品状态会由“输入” 状态转变为“准备中”，如果被出品制单程序处理后，会变为“制作中”或者“完工”状态。

相应的菜品状态有：1.输入 ----- 刚刚输入还没有提交（可以取消） 2.准备中 -----已经提交，但是出品制单程序还没有打印处理 3.制作中----出品制单程序已经打印过了 4.完工----出品制单程序已经划菜出品了 5.取消----该菜品已经被取消了 6.组合状态[免费] ----该菜品被执行了 免费。


主题:好易酒店管理系统 用户权限使用说明

为了满足不同岗位不同操作权限的管理需要,本系统采用了多用户管理机制.主要设计原理是:

1. 支持多个用户

2. 每个用户的标识由”工号”.”姓名”,”密码”,”最低折扣率”,”权限”,”岗位”组成

”工号”---由英文字母或者数字组成,可以跟员工编号相同,

”最低折扣率”---指收银员在前台结账的界面上可以操作的最低的折扣率.如果是低于其限制的折扣率,那么可以通过刷经理卡来解决

“权限”---通过把系统中的一些关键操作通过权限来控制起来可以提高安全性,比如:给客人执行全单打折,这么一个操作,我们可以通过√来进行选择,被√上表示该用户可以执行此操作,否则不允许.

“岗位”---好易无线点菜系统专用,”点菜员”级别的用户才在PDA上显示.

3. 用户管理,每个用户有一个密码,以Admin[系统管理员]用户登录”数据中心”模块后,可以执行用户权限管理,该Admin可以修改任何人的工号,密码和权限等等所有信息

4. 密码管理:Admin可以修改任何用户的密码(在数据中心).普通用户可以工作前台,以自己的工号的密码登录后,选择修改自己的密码(此功能主要防止员工之间相互盗号),员工修改自己的密码必须知道原始密码,以防止非法修改别人的密码.

5. 数据删除,部分已经被使用的工号可能不会被允许删除,可能需要导出数据或者初始化业务数据后才允许删除用户.


主题:Admin[系统管理员]登录数据中心,执行用户权限管理

1.双击桌面上的”数据中心”图标

2.启动程序后,出现登录窗口,工号输入 Admin 密码输入自定义的密码,效果如下图所示

3.登录成功后,在数据中心的左边,点击”用户权限”条目,窗口右边会出现用户列表,如下图

4.用鼠标双击某一用户会进入修改用户资料的界面,如下图所示,可以修改权限,密码之类.

5.选中用户后点击工具条上的”删除”按钮可以删除选中的用户,点击新建按钮可以弹出新建用户的界面.

6.所有操作完毕后,客户端重新登录系统后生效


报表设计器使用指南

主题：

1. 报表设计器适用场合？

2. 如何打开报表设计器？

3. 如何设置报表纸张大小？

4. 如何指定每页打印行数？

5. 如何指定是否横向打印？

6. 如何取默认值，让表格快速显示出来？

7. 如何调整各列宽度？

8. 如何调整各行高度？

9. 如何调整报表标题字体大小位置等？

10. 如何调整报表其它项目（起始日期、截止日期等）？

11. 如何给报表添加自定义打印项目？

12. 如何保存报表格式？

13. 如何打印报表【打印多份，打印指定页，指定打印机】？

1. 报表设计器适用场合：
在餐饮管理系统的报表查询里面，我们可以查询当日销售菜品汇总，营业汇总等等各种报表。有时我们需要将这些报表打印出来，这时我们需要用到“报表设计器”。该报表设计器是个通用的软件模块，主要功能是将各种报表程序统计出来的表格化的数据，以自定义的格式打印到A4纸张幅面上【当然纸张大小可以任意指定】。界面如下图所示：

2. 如何打开报表设计器？
在好易餐饮管理系统、好易进销存管理系统、好易会员管理系统模块里面都有相应的统计报表，在统计报表指定所需条件，统计出所需数据后，点击菜单“文件”-“打印预览”，一般会调出报表设计器界面。

3. 如何设置报表纸张大小？
在报表设计器左边有个项目列表，选择“纸张宽度”项目，表格下部会显示“纸张宽度”项目的基本属性，如：坐标、标题值、字体大小等。如下图所示：

如图所示，对于“纸张宽度”“纸张高度”等项目，其坐标、字体名称、字体大小等属性无效，只有标题值项目有效，如图填写210表示A4纸的宽度。纸张高度可以填写A4纸的高度297，其它纸张可以根据实际大小填写，单位均为毫米。

4. 如何指定每页打印行数？
如上所示，只需在项目列表里面找到“每页打印的行数”项目，在标题值里面填写指定的行数，A4值一般填写40，配合行高度可以填写合适的数字。

5. 如何指定是否横向打印？
有时我们需要根据报表调整纸张打印方向，比如横向和纵向打印，只需在项目列表里面选择“横向打印”项目，在其标题值里面填写“是”即可，如果是纵向打印，填写“否”或者保持空白不填。如下图：

6. 如何取默认值，让表格快速显示出来？
有时，当我们的报表设计格式文件丢失后，可能导致报表没有任何信息，无法给予我们基本设置信息的困难。请按照如下步骤操作：
a、进入报表设计器界面
b、设置报表的纸张宽度和高度
c、点击菜单“文件”-“取默认值”如下图所示：

d、一般情况下，已经可以看到报表雏形，再对其进行一些微调就可以了。

7. 如何调整各列宽度？
在报表的纸张宽度高度等基本属性设置好后，有时需要根据纸张幅面大小和报表内容，进行列宽度调整，以便让需要的数据显示在有效的纸张范围内，请选择菜单“文件”-“表格设置”，出现如下图所示窗口：

通过在表格里面设置列的宽度（以毫米为单位）（注意：在宽度列通过回车键开始编辑，编辑完毕按回车键确认输入）。在对齐列上通过双击鼠标左键在“左对齐”“居中”和“右对齐”之间做出选择，最后点击确定后生效（还需要点击保存才永久有效）。

8. 如何调整各行高度？
跟设置“每页打印行数”项目类似，选择“每行高度（MM）”项目，如下图所示，在标题值项目输入每行高度（以毫米为单位）：

9. 如何调整报表标题字体大小位置等？
首先需要选择指定的项目（方法有2：在项目列表框中选择或者在右边预览区用鼠标点击选择）如下图设置报表标题项目的字体和大小等：

当前被选中的项目，其外框会有6个小框，表示其选中状态。再到左边的设置框里面设置横坐标和总坐标的值，或者直接用鼠标拖动到合适的位置。最后保存生效。另外所有非控制项目，其是否打印项目可以在“是”和“否”之间选择。

10. 如何调整报表其它项目（起始日期、截止日期等）？
如9所示，可以选择所有打印项目的坐标、字体、大小、是否打印等。不同于自定义打印项目，这些项目一般是程序传递进来的，有动态的值，比如日期范围等。

11. 如何给报表添加自定义打印项目？
点击菜单“文件”-“添加自定义打印项目”，弹出如下所示窗口：

在这个窗口中输入自定义打印内容，然后再像其它项目一样设置其坐标和字体等信息。

12. 如何保存报表格式？
上述各种项目都设置好后，请点击【保存】按钮，或者点击菜单“文件”-“保存设置”，将设置好的信息保存下来。

13. 如何打印报表【打印多份，打印指定页，指定打印机】？
保存好报表格式后，可以点击【打印】按钮，弹出选择打印机窗口，如下图所示：

在这个窗口中可以选择打印机以及打印范围和打印份数，点击【打印】按钮开始打印.

作者：好易软件

163_zhp@163.com


Document Title

rguo


好易餐饮管理系统安装指南

作者:章华平

电话:13777770571

EMail:163_zhp@163.com

一、安装步骤

1.卸载旧的数据库系统(如果是新客户安装或者无旧数据,请跳过此步骤)

打开控制面板,打开"添加删除"程序项目,选择Microsoft SQL Server项目,执行卸载操作,完成后重新启动计算机.

2.备份数据库和配置文件(如果是新客户安装或者无旧数据,请跳过此步骤)

备份方法:在主机上拷贝D:\HH目录到另外的磁盘分区留做备份(必须在第一步骤完成后才能执行)

3.卸载旧的餐饮软件(如果是新客户安装或者无旧数据,请跳过此步骤)

在屏幕右下角的好易餐饮服务器上点击右键菜单选择退出,然后打开控制面板,打开"添加删除"程序项目,选择"好易餐饮管理系统"项目,执行卸载操作,完成后重新启动计算机.此步骤完成后D:\HH应该消失,如果没有消失,建议删除该目录.

4.安装新的数据库系统

打开光盘上的 G:\MSDE 目录,运行Setup.exe,待其执行完毕后重新启动计算机,应该在屏幕右下角看到SQL Server的服务管乐器状态为运行中.关于此步骤的安装如有问题,请参考SQL Server安装手册.

5.安装新的餐饮软件

打开光盘上的 G:\餐饮 目录,运行Setup.exe,按照其向导逐步完成安装(如果没有必要,中间的可选择项目,完全可以采用默认设置).

注意:如果我们需要使用旧版本的文件和数据,请在安装向导的最后一步,不要选中"创建数据库"选项.

6.恢复使用旧的数据库和配置文件

把新的安装程序安装目录(默认是D:\HH)删除掉.

把旧的备份的文件夹HH覆盖到D:\HH.

打开D:\HH\DBUpdate.exe程序,点击创建数据库.

完成设置,打开桌面上的快捷图标.


===============================================================================

欢迎使用"好易餐饮管理系统"V3.0

版权所有:好易软件工作室

QQ:4108173 手机:013777770571

联系人:章华平

===============================================================================

一、第一次使用本软件？

注意：本系统默认数据库中的普通用户“工号”为“111”，口令为“111”，管理员“工号”固定为“Admin”，口令初始值为“12345”，需正确登陆后才能使用。

二、如何删除数据库中的原始数据资料？

请使用管理员账号登陆“数据中心”模块，点击菜单“查看”->“清空系统数据”。

三、如何建立自己酒店的数据库？

在清空原始数据资料后，请分别在“数据中心”模块按照顺序建立如下资料：厨房/菜品单位/菜品分类/菜品销售财务核算分类/菜品资料/餐桌分区资料/餐桌资料/签单客户资料等等。

四、如何自定义收银账单打印格式？

打开安装目录下的“billstp.exe”账单设计器程序进行收银账单打印格式设置，设置完毕保存即可。

五、在哪里完成输单收银的工作？

打开桌面上的“前台收银”快捷方式，点击联机，输入“工号”和“口令”登陆系统，开始输单、结账。

六、在哪里查看营业报表数据？

打开桌面上的“报表查询工具”快捷方式，输入“工号”和“口令”登陆系统，即可以查看报表数据并且打印。

七、如何获取详细的技术支持信息？

请联系好易软件工作室，通过电话013777770571 0577-88330371 81669046，或者QQ:4108173 EMail:4108173@qq.com 等等方式联系我们的技术人员，您将会获得详细的技术支持信息！


好易餐饮管理系统钟点计费使用特别说明

作者:章华平 2006.04.21

1.在高级数据中心AdvDmc.exe中,选择"菜品资料"->"钟点消费项目"中维护好"钟点消费项目",如: 足浴项目(编号:A,名称:足浴,助记符:ZY,单位:元,单价:20,分钟数:45(即:每个钟45分钟)

2.在高级数据中心AdvDmc.exe中,打开"查看"->"选项"->"KTV",选中"开启钟点计费功能"

3.在收银界面,如果某张餐桌需要钟点计费,则在开台后手工输入一条菜品记录如上面说的:足浴,数量为1,那么系统将自动会后续按照设定的标准计算钟点消费

4.注意:因为系统会自动产生多个重复的钟点数计费项目,因此建议账单打印设计为"合并菜品数量后打印"

5.注意:开启了钟点计费后,其中之一的收银电脑必须一直保持开机状态,以免漏计费用


教你如何正确安装打印机

佚名　中关村在线 | 2006-07-20 10:49:07 |

引:打印机的安装分2个步骤：硬件安装和驱动程序安装。这两个步骤的顺序不定，视打印机不同而不同。如果是串口打印机一般先接打印机，然后再装驱动程序，如果是USB口的打印机一般先装驱动程序再接打印机。

打印机的安装分2个步骤：硬件安装和驱动程序安装。这两个步骤的顺序不定，视打印机不同而不同。如果是串口打印机一般先接打印机，然后再装驱动程序，如果是USB口的打印机一般先装驱动程序再接打印机。

一、打印机硬件安装

实际上现在计算机硬件接口做得非常规范，你把打印机得数据线只有一端在计算机上能接，所以不会接错。这个部分略。

二、驱动程序安装

如果驱动程序安装盘是以可执行文件方式提供，则最简单直接运行SETUP.exe就可以按照其安装向导提示一步一步完成。

如果只提供了驱动程序文件，则安装相对麻烦。这里以Windows XP系统为例介绍。首先打开控制面板，然后双节面板中的打印机和传真图标。如下图

接着弹出如下窗口：

这个窗口将显示所有已经安装了的打印机（包括网络打印机）。安装新打印机直接点左边的添加打印机，接着弹出添加打印机向导，

点下一步，出现如下窗口询问是安装本地打印机还是网络打印机，默认是安装本地打印机：

（1）如果安装本地打印机直接点下一步，系统将自动检测打印机类型，如果系统里有该打印机的驱动程序，系统将自动安装。如果没有自动安装则会报一个错，点下一步出现如下窗口：

这里一般应使用默认值，点下一步，弹出询问打印机类型的窗口：

如果能在左右列表中找到对应厂家和型号，则直接选中然后点下一步；如果没有则需要我们提供驱动程序位置，点从磁盘安装，然后在弹出的对话框中选择你驱动程序所在位置，比如软驱，光盘等，找到正确位置后点打开（如果提供位置不正确，点打开后将没有相应，暗示你重新选择），系统将开始安装，然后系统提示你给正在安装的打印机起个名字，并询问是否做为默认打印机（即发出打印命令后，进行相应的那一台），如下图：

选择后点下一步。然后出现如下窗口，询问是否打印测试页，一般新装的打印机都要测试：

选择后点下一步，最后点确定，完成整个安装过程。


主题: 好易酒店管理系统再开发接口

好易酒店系统采用了开放式的设计模式,您可以自己通过其提供的接口对其进行扩充.

例1:用Excel通过接口往系统中添加会员资料,以下代码可以直接拷贝至Excel宏里面执行,稍加修改即可以对其它软件提供的Excel表格中的客户资料进行导入操作.

Private Sub CommandButton1_Click()

Dim obj As Object
Dim strCode As String
Dim i As Integer
Set obj = CreateObject("AdvDmc.Document")
For Row = 2 To 1148 '1121
strCode = Sheet1.Cells(Row, 2)
strCode = Trim(strCode)
If Not strCode = "" Then
If Len(strCode) < 5 Then
For i = 1 To 5 -
Len(strCode)
strCode = "0" & strCode
Next
End If
If obj.saveclient(Sheet1.Cells(Row, 1), _
strCode, _
Sheet1.Cells(Row, 3), _
Sheet1.Cells(Row, 4), _
Sheet1.Cells(Row, 5)) <= 0 Then
Sheet1.Cells(Row, 7) = "失败"
End If
End If
Next
Set obj = Nothing
MsgBox "保存成功!"

End Sub


Q:为什么收银程序中套餐明细建立好后,而点了套餐,既不发送明细,打印结账单时也不打印明细出来?

A:你需要用管理员[Admin]登录数据中心,选择”查看”->”选项”->”高级” 将”收银程序支持下单模式”的复选框选中,保存,再重新打开收银程序就可以了.原因在于:只有在收银程序支持下单模式的时候才会弹出套餐明细,但是下单程序(HyPos.exe)中不管如何设置都会自动弹出套餐明细!2006-8-5


技术支持信息

温州市好易软件

地址: 浙江省温州市民航路文景花苑2号楼1007

电话:0577-88330371

邮政编码: 325000

EMail: 163_zhp@163.com

网址: http://www.goodeasy.net.cn

http://goodeasy.meibu.com

http://wzgsl.3322.org

QQ: 4108173

MSN: 163_zhp@163.com

账号:

中国农业银行:95599 8033 02101 71410 户名:章华平


如何开始使用

请参阅如下主题:

1、清除系统自带的演示数据资料

2、建立自己酒店的菜品资料库

3、建立自己酒店的客户资料库

4、建立自己酒店的餐桌资料库

5、设计符合自己酒店要求收银账单的打印格式

6、设计符合自己酒店要求的报表打印格式


主题：建立自己酒店的菜品资料库

如图: